Kubernetes Gitlab-Runner

I’m testing out the kubernetes gitlab integration and auto devops. Everything works well with the k8 configuration. My problem is the install gitlab-runner button in project -> ci -> kubernetes installs the runner in my cluster but doesn’t take into account my privately signed certs. So I get the “x509: certificate signed by unknown authority” in the logs from the runner. I have tried using kubectl to copy my cert to the running pod but the default user is gitlab-runner and doesn’t have permission to write to /etc/gitlab-runner. Is there a way to alter that automated runner install to include the copy of my cert in /etc/gitlab-runner/certs/?

Second this. Helm Tiller installation works, but I get same error trying to install runner / prometheus via Gitlabs Auto DevOps.

Where does the certificates in values-content-configuration-runner are coming from?

I’ve followed the docs here https://docs.gitlab.com/ee/install/kubernetes/gitlab_runner_chart.html

Generated the secret from my custom internal cert, and specified the runner to use it:

kubectl --namespace kube-system create secret generic my-cert --from-file=my_ca.crt
helm install --namespace kube-system --name gitlab-runner -f values.yaml gitlab/gitlab-runner

But getting this error from the docker container that’s performing the installation:

Registration attempt 30 of 30
Runtime platform                                    arch=amd64 os=linux pid=345 revision=8bb608ff version=11.7.0
WARNING: Running in user-mode.
WARNING: The user-mode requires you to manually start builds processing:
WARNING: $ gitlab-runner run
WARNING: Use sudo for system-mode:
WARNING: $ sudo gitlab-runner...
ERROR: Registering runner... failed                 runner=X5v7mRCb status=couldn't execute POST against https://git.server/api/v4/runners: Post https://git.server/api/v4/runners: x509: certificate signed by unknown authority
PANIC: Failed to register this runner. Perhaps you are having network problems