Mirrored repositories are not working

I need help with Mirroring repositories. I had set up mirroring a GitLab repo with AWS CodeCommit repo. It was working fine. But from yesterday suddenly it is not working. I didn’t make any modifications to Gitlab settings or in AWS CodeCommit. I tried clicking on the update now icon but it shows " The remote repository is being updated…", but it doesn’t show any error message neither updating last update attempt time. Also, I deleted the repo and added it again, but nothing helps. I attached the screenshot. I didn’t understand where is the problem. Can anyone help me to identify the problem, please?

1 Like

I’m having the same problem with all repos on /mailtop group.

I have the same issue too. All my mirroring repositories have stop working today.

It seems other users are facing the same issue. Why not Gitlab core team working on it nor giving us any update? How can we inform them? They even don’t care because I am not paying them, I informed them through support@gitlab.com they replied me to post in forum.

1 Like


sorry for the trouble here. I was able to reproduce the problem and found a possible error message which could help. During my research on the issue tracker I have found an issue already being debugged and added my findings there: https://gitlab.com/gitlab-org/gitlab/-/issues/242061#note_404692820

It seems that Gitaly handling the Git requests is not passing or using the oauth token properly, but this is just a blind guess of mine. For future analysis and updates, please subscribe to the issue notifications at the bottom right.


Edit: My assumption was wrong, this turned out to be a configuration problem. The real problem is a security sanitizer fix which was too aggressive.



here’s the incident issue: https://gitlab.com/gitlab-com/gl-infra/production/-/issues/2603 and an update:


1 Like

Sorry for the trouble. It should be working again. See https://gitlab.com/gitlab-com/gl-infra/production/-/issues/2603 for more details.

1 Like

I am having the same problem.
Version 13.4.1-ee
Also after I upgraded to 13.4.3-ee

I am trying to push from a gitlab repository to a gitblit repository on the same server with a different port number.

If target is ssh://peteryoung@git:29418/~peteryoung/configs.git and I use SSH Public key authentication it just shows:
The remote repository is being updated.
Last attempt: Never
This stays the same even if I wait for 12 hours.

Or sometimes I get
Failed to add the RSA host key for IP address ‘…’ to the list of known hosts

Or sometimes I get cannot resolve hostname

If target is
I get an error SSL certificate problem: unable to get local issuer certificate

If i do git push --mirror it works from command line.
Whatever I try I can’t get it to work with gitlab.

Can anyone help ?

I have now got it working my using ssh and copying the public key to the target server.

This have never worked for me, regardless the version I was using… seems like a left-over from staging

I have the same problem, mirror doesn’t run. I was on 13.6.1-ee and updated to 13.9.1-ee but still doesn’t work.