[new Install] 502 Whoops, GitLab is taking too much time to respond

Hello,

I had a instance of gitlab-ce and I updated it with apt upgrade. Since then, it is not working.
It was not very used, so I have made a backup and tried to reinstall it from scratch and it still doesn’t work.

If someone have the answer, it would be great !

Here is the output of gitlab-ctl tail.

https://pastebin.com/3hsR8mgf

If you haven’t yet, give the instance a few minutes. I honestly do not know the root cause, but the whole system usually takes a few minutes to startup and before reachable from the outer world.

Hi @ultrusse, welcome to the GitLab community forum! :tada:

What version of GitLab were you using before the upgrade?

If GitLab was not updated in the past two months, I suggest reverting to backup and folowing the upgrade recommendations here: https://docs.gitlab.com/ee/policy/maintenance.html#upgrade-recommendations

If you updated GitLab regularly before this occurred, I suggest trying gitlab-ctl reconfigure followed by gitlab-ctl restart to see if this resolves the issue.

Let us know how it goes.

Hello,

Thank you for your answers. I didn’t know these recommendations.
I managed to downgrade to 12.10.11 (and restore all the data/secrets).

I followed the recommendation and tried to upload to 13.0.1-ce.0.
I trying gitlab-ctl reconfigure && gitlab-ctl restart and wait for 10 minutes.

But I still got 502 error.