New install not running 502 error

I have a new install of gitlab-ce 12.4.1 on a debian container on SmartOs, I cannot get a response on my requests, only 502 error.
My setup uses a reverse proxy.

Output of gitlab-ctl tail after one request

Output of gitlab-rake gitlab:check

Checking GitLab subtasks ...

Checking GitLab Shell ...

GitLab Shell: ... GitLab Shell version >= 10.2.0 ? ... OK (10.2.0)
Running /opt/gitlab/embedded/service/gitlab-shell/bin/check
gitlab-shell self-check failed
  Try fixing it:
  Make sure GitLab is running;
  Check the gitlab-shell configuration file:
  sudo -u git -H editor /opt/gitlab/embedded/service/gitlab-shell/config.yml
  Please fix the error above and rerun the checks.

Checking GitLab Shell ... Finished

Checking Gitaly ...

Gitaly: ... default ... OK

Checking Gitaly ... Finished

Checking Sidekiq ...

Sidekiq: ... Running? ... no
  Try fixing it:
  sudo -u git -H RAILS_ENV=production bin/background_jobs start
  For more information see:
  doc/install/ in section "Install Init Script"
  see log/sidekiq.log for possible errors
  Please fix the error above and rerun the checks.

Checking Sidekiq ... Finished

Checking Incoming Email ...

Incoming Email: ... Reply by email is disabled in config/gitlab.yml

Checking Incoming Email ... Finished

Checking LDAP ...

LDAP: ... LDAP is disabled in config/gitlab.yml

Checking LDAP ... Finished

Checking GitLab App ...

Git configured correctly? ... yes
Database config exists? ... yes
All migrations up? ... yes
Database contains orphaned GroupMembers? ... no
GitLab config exists? ... yes
GitLab config up to date? ... yes
Log directory writable? ... yes
Tmp directory writable? ... yes
Uploads directory exists? ... yes
Uploads directory has correct permissions? ... yes
Uploads directory tmp has correct permissions? ... skipped (no tmp uploads folder yet)
Init script exists? ... skipped (omnibus-gitlab has no init script)
Init script up-to-date? ... skipped (omnibus-gitlab has no init script)
Projects have namespace: ... can't check, you have no projects
Redis version >= 2.8.0? ... yes
Ruby version >= 2.5.3 ? ... yes (2.6.3)
Git version >= 2.22.0 ? ... yes (2.22.0)
Git user has default SSH configuration? ... yes
Active users: ... 0
Is authorized keys file accessible? ... yes

Checking GitLab App ... Finished

Checking GitLab subtasks ... Finished

So apparently sidekiq is not running.

Output of gitlab-ctl status

run: alertmanager: (pid 49217) 557s; run: log: (pid 49210) 557s
run: crond: (pid 49262) 557s; run: log: (pid 49258) 557s
run: gitaly: (pid 49219) 557s; run: log: (pid 49213) 557s
run: gitlab-exporter: (pid 49261) 557s; run: log: (pid 49255) 557s
run: gitlab-workhorse: (pid 49215) 557s; run: log: (pid 49214) 557s
run: grafana: (pid 49259) 557s; run: log: (pid 49254) 557s
run: logrotate: (pid 49216) 557s; run: log: (pid 49209) 557s
run: nginx: (pid 49329) 557s; run: log: (pid 49328) 557s
run: postgres-exporter: (pid 49218) 557s; run: log: (pid 49212) 557s
run: postgresql: (pid 49260) 557s; run: log: (pid 49252) 557s
run: prometheus: (pid 49263) 557s; run: log: (pid 49253) 557s
run: redis: (pid 49325) 557s; run: log: (pid 49324) 557s
run: redis-exporter: (pid 49266) 557s; run: log: (pid 49256) 557s
run: sidekiq: (pid 49220) 557s; run: log: (pid 49211) 557s
run: unicorn: (pid 49264) 557s; run: log: (pid 49257) 557s

Gitlab config file: grep -v "^#\|^$" < gitlab.rb

external_url ''
nginx['listen_port'] = 80
nginx['listen_https'] = false
nginx['proxy_set_headers'] = {
 "X-Forwarded-For" => "$proxy_add_x_forwarded_for",
 "X-Forwarded-Proto" => "https",
node_exporter['enable'] = false
letsencrypt['enable'] = false

Let me know if you need other data.

Output from gitlab-workhorse after a request:

==> /var/log/gitlab/gitlab-workhorse/current <==
{"correlation_id":"pX6zxjb96x7","error":"badgateway: failed after 0s: dial unix /var/opt/gitlab/gitlab-rails/sockets/gitlab.socket: connect: no such file or directory","level":"error","method":"GET","msg":"error","time":"2019-11-11T12:13:22Z","uri":"/"}
{"correlation_id":"pX6zxjb96x7","duration_ms":0,"host":"","level":"info","method":"GET","msg":"access","proto":"HTTP/1.1","referrer":"","remote_addr":"<filtered>:0","remote_ip":"<filtered>","status":502,"system":"http","time":"2019-11-11T12:13:22Z","uri":"/","user_agent":"Mozilla/5.0 (X11; Linux x86_64; rv:71.0) Gecko/20100101 Firefox/71.0","written_bytes":2940}

According to this could be related to unicorn not starting, but my system is not out of memory as in that issue. Also seems related, but I do not have a port conflict.

I followed
It seems I’m out of shared memory:

free -m:

              total        used        free      shared  buff/cache   available
Mem:           4096         949        3146           0           0        3146
Swap:          4096           0        4096

Edit: I’m not sure that this is actually the problem, I have another gitlab install running in another container, which also has a 0 in the shared column but runs fine (on an older version, which I cannot upgrade because I run into the same problem)

Apparently there is an issue with system calls that makes running gitlab on a smartos container not possible at the moment, it is being worked on.