Raspberry 502 Error GitLab Shell Internal API unreachable

Hey, guys.
Im trying to run a GitLab instance on my Raspberry 4.
It was easy to install, but I always got the 502 Error when trying to reach the website.
I did a bunch of stuff following multiple solutions from forum questions (I did so much i cant remember what i did). Then it started working. I created two Repositories, all worked perfectly. Then I did a reboot and now im back at the 502 Error.
Runnung sudo gitlab-rake gitlab:check gives me:

Checking GitLab subtasks ...

Checking GitLab Shell ...

GitLab Shell: ... GitLab Shell version >= 14.28.0 ? ... OK (14.28.0)
Running /opt/gitlab/embedded/service/gitlab-shell/bin/check
Internal API available: FAILED - Internal API unreachable
gitlab-shell self-check failed
  Try fixing it:
  Make sure GitLab is running;
  Check the gitlab-shell configuration file:
  sudo -u git -H editor /opt/gitlab/embedded/service/gitlab-shell/config.yml
  Please fix the error above and rerun the checks.
[...rest works fine]

The File /opt/gitlab/embedded/service/gitlab-shell/config.yml shows:

# Url to gitlab instance. Used for api calls. May but need not end with a slash.
gitlab_url: "http+unix://%2Fvar%2Fopt%2Fgitlab%2Fgitlab-workhorse%2Fsockets%2Fsocket"

My Configuration /etc/gitlab/gitlab.rb is all comments, except:

external_url 'http://gitlab.local'

I added to my /etc/hosts File the line:         gitlab.local

Im not sure if the gitlab_url from the config.yml is right, but i simply dont know.
I am out of ideas and really frustrated, because it worked for a day until I rebooted the raspberry.
I feel like i tried everything, but I cant get it running… I would really appreciate if someone would help me with this. Thanks guys.