No update found in Ubuntu eventhough there's new release 11.11

Hi,

I have a self hosted Gitlab (11.10.4) and it did tell me there’s an update available. When I checked on Gitlab release page, indeed there’s an update to 11.11.

But when I try to update, apt update && apt upgrade says nothing to upgrade.

Please advice. Thanks

What version of Ubuntu are you running?

Can you share the output of the following commands:

sudo apt update &&
sudo apt upgrade gitlab-ee -y &&
sudo apt list gitlab-ee &&
sudo gitlab-rake gitlab:env:info

Best Regards,
Greg

I’m using Ubuntu 14.04

Here are the output of above command (I’ve change ee to ce)

# apt update && apt upgrade gitlab-ce -y && apt list gitlab-ce && gitlab-rake gitlab:env:info
Ign http://mirrors.digitalocean.com trusty InRelease
Hit http://security.ubuntu.com trusty-security InRelease
Hit http://mirrors.digitalocean.com trusty-updates InRelease
Get:1 https://apt.datadoghq.com stable InRelease
Ign https://apt.datadoghq.com stable InRelease
Hit https://apt.datadoghq.com stable Release.gpg
Hit http://security.ubuntu.com trusty-security/main Sources
Hit https://apt.datadoghq.com stable Release
Hit http://mirrors.digitalocean.com trusty-backports InRelease
Hit https://apt.datadoghq.com stable/main amd64 Packages
Hit https://apt.datadoghq.com stable/main i386 Packages
Get:2 https://apt.datadoghq.com stable/main Translation-en
Ign https://apt.datadoghq.com stable/main Translation-en
Hit http://security.ubuntu.com trusty-security/universe Sources
Hit http://mirrors.digitalocean.com trusty Release.gpg
Hit http://security.ubuntu.com trusty-security/main amd64 Packages
Hit http://mirrors.digitalocean.com trusty-updates/main Sources
Hit http://security.ubuntu.com trusty-security/universe amd64 Packages
Hit http://mirrors.digitalocean.com trusty-updates/restricted Sources
Hit http://security.ubuntu.com trusty-security/main i386 Packages
Hit http://mirrors.digitalocean.com trusty-updates/universe Sources
Hit http://security.ubuntu.com trusty-security/universe i386 Packages
Hit http://mirrors.digitalocean.com trusty-updates/multiverse Sources
Hit http://security.ubuntu.com trusty-security/main Translation-en
Hit http://mirrors.digitalocean.com trusty-updates/main amd64 Packages
Hit http://security.ubuntu.com trusty-security/universe Translation-en
Hit http://mirrors.digitalocean.com trusty-updates/restricted amd64 Packages
Hit http://mirrors.digitalocean.com trusty-updates/universe amd64 Packages
Hit http://mirrors.digitalocean.com trusty-updates/multiverse amd64 Packages
Hit https://packages.gitlab.com trusty InRelease
Hit http://mirrors.digitalocean.com trusty-updates/main i386 Packages
Hit http://mirrors.digitalocean.com trusty-updates/restricted i386 Packages
Hit http://mirrors.digitalocean.com trusty-updates/universe i386 Packages
Hit https://packages.gitlab.com trusty/main amd64 Packages
Hit http://mirrors.digitalocean.com trusty-updates/multiverse i386 Packages
Hit http://mirrors.digitalocean.com trusty-updates/main Translation-en
Hit https://packages.gitlab.com trusty/main i386 Packages
Hit http://mirrors.digitalocean.com trusty-updates/multiverse Translation-en
Get:3 https://packages.gitlab.com trusty/main Translation-en
Hit http://mirrors.digitalocean.com trusty-updates/restricted Translation-en
Hit http://mirrors.digitalocean.com trusty-updates/universe Translation-en
Hit http://mirrors.digitalocean.com trusty-backports/main Sources
Hit http://mirrors.digitalocean.com trusty-backports/restricted Sources
Hit http://mirrors.digitalocean.com trusty-backports/universe Sources
Ign https://packages.gitlab.com trusty/main Translation-en
Hit http://mirrors.digitalocean.com trusty-backports/multiverse Sources
Hit http://mirrors.digitalocean.com trusty-backports/main amd64 Packages
Hit http://mirrors.digitalocean.com trusty-backports/restricted amd64 Packages
Hit http://mirrors.digitalocean.com trusty-backports/universe amd64 Packages
Hit http://mirrors.digitalocean.com trusty-backports/multiverse amd64 Packages
Hit http://mirrors.digitalocean.com trusty-backports/main i386 Packages
Hit http://mirrors.digitalocean.com trusty-backports/restricted i386 Packages
Hit http://mirrors.digitalocean.com trusty-backports/universe i386 Packages
Hit http://mirrors.digitalocean.com trusty-backports/multiverse i386 Packages
Hit http://mirrors.digitalocean.com trusty-backports/main Translation-en
Hit http://mirrors.digitalocean.com trusty-backports/multiverse Translation-en
Hit http://mirrors.digitalocean.com trusty-backports/restricted Translation-en
Hit http://mirrors.digitalocean.com trusty-backports/universe Translation-en
Hit http://mirrors.digitalocean.com trusty Release
Hit http://mirrors.digitalocean.com trusty/main Sources
Hit http://mirrors.digitalocean.com trusty/restricted Sources
Hit http://mirrors.digitalocean.com trusty/universe Sources
Hit http://mirrors.digitalocean.com trusty/multiverse Sources
Hit http://mirrors.digitalocean.com trusty/main amd64 Packages
Hit http://mirrors.digitalocean.com trusty/restricted amd64 Packages
Hit http://mirrors.digitalocean.com trusty/universe amd64 Packages
Hit http://mirrors.digitalocean.com trusty/multiverse amd64 Packages
Hit http://mirrors.digitalocean.com trusty/main i386 Packages
Hit http://mirrors.digitalocean.com trusty/restricted i386 Packages
Hit http://mirrors.digitalocean.com trusty/universe i386 Packages
Hit http://mirrors.digitalocean.com trusty/multiverse i386 Packages
Hit http://mirrors.digitalocean.com trusty/main Translation-en
Hit http://mirrors.digitalocean.com trusty/multiverse Translation-en
Hit http://mirrors.digitalocean.com trusty/restricted Translation-en
Hit http://mirrors.digitalocean.com trusty/universe Translation-en
Reading package lists... Done
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
gitlab-ce is already the newest version.
The following packages were automatically installed and are no longer required:
  amd64-microcode linux-base linux-headers-3.13.0-170
Unpacking linux-modules-extra-3.13.0-170-generic (3.13.0-170.220) ...
Selecting previously unselected package amd64-microcode.
Preparing to unpack .../amd64-microcode_3.20180524.1~ubuntu0.14.04.2+really20130710.1ubuntu1_amd64.deb ...
Unpacking amd64-microcode (3.20180524.1~ubuntu0.14.04.2+really20130710.1ubuntu1) ...
Processing triggers for man-db (2.6.7.1-1ubuntu1) ...
Setting up ubuntu-advantage-tools (10ubuntu0.14.04.3) ...
Setting up ubuntu-minimal (1.325.1) ...
Setting up linux-base (4.5ubuntu1~14.04.1) ...
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Setting up linux-headers-3.13.0-170 (3.13.0-170.220) ...
Setting up linux-headers-3.13.0-170-generic (3.13.0-170.220) ...
Setting up linux-modules-3.13.0-170-generic (3.13.0-170.220) ...
Setting up linux-image-3.13.0-170-generic (3.13.0-170.220) ...
I: /vmlinuz.old is now a symlink to boot/vmlinuz-3.13.0-85-generic
I: /initrd.img.old is now a symlink to boot/initrd.img-3.13.0-85-generic
I: /vmlinuz is now a symlink to boot/vmlinuz-3.13.0-170-generic
I: /initrd.img is now a symlink to boot/initrd.img-3.13.0-170-generic
Setting up linux-modules-extra-3.13.0-170-generic (3.13.0-170.220) ...
Setting up amd64-microcode (3.20180524.1~ubuntu0.14.04.2+really20130710.1ubuntu1) ...
update-initramfs: deferring update (trigger activated)
Processing triggers for linux-image-3.13.0-170-generic (3.13.0-170.220) ...
/etc/kernel/postinst.d/initramfs-tools:
update-initramfs: Generating /boot/initrd.img-3.13.0-170-generic
/etc/kernel/postinst.d/zz-update-grub:
Generating grub configuration file ...
Found linux image: /boot/vmlinuz-3.13.0-170-generic
Found initrd image: /boot/initrd.img-3.13.0-170-generic
Found linux image: /boot/vmlinuz-3.13.0-85-generic
Found initrd image: /boot/initrd.img-3.13.0-85-generic
Found linux image: /boot/vmlinuz-3.13.0-79-generic
Found initrd image: /boot/initrd.img-3.13.0-79-generic
Found memtest86+ image: /boot/memtest86+.elf
Found memtest86+ image: /boot/memtest86+.bin
done
Processing triggers for initramfs-tools (0.103ubuntu4.11) ...
update-initramfs: Generating /boot/initrd.img-3.13.0-170-generic
Listing... Done
gitlab-ce/trusty,now 11.10.4-ce.0 amd64 [installed]


System information
System:		Ubuntu 14.04
Current User:	git
Using RVM:	no
Ruby Version:	2.5.3p105
Gem Version:	2.7.6
Bundler Version:1.17.3
Rake Version:	12.3.2
Redis Version:	3.2.12
Git Version:	2.18.1
Sidekiq Version:5.2.5
Go Version:	unknown

GitLab information
Version:	11.10.4
Revision:	62c464651d2
Directory:	/opt/gitlab/embedded/service/gitlab-rails
DB Adapter:	PostgreSQL
DB Version:	9.6.11
URL:		http://srv.nazrol.tech
HTTP Clone URL:	http://srv.nazrol.tech/some-group/some-project.git
SSH Clone URL:	git@srv.nazrol.tech:some-group/some-project.git
Using LDAP:	no
Using Omniauth:	yes
Omniauth Providers:

GitLab Shell
Version:	9.0.0
Repository storage paths:
- default: 	/var/opt/gitlab/git-data/repositories
GitLab Shell path:		/opt/gitlab/embedded/service/gitlab-shell
Git:		/opt/gitlab/embedded/bin/git

Hi @wmfairuz and welcome to the forum. Thanks for the info and prompt response.

You mention that you’re using Ubuntu 14.04, which reached end of life as of April 2019. This means it will no longer receive security and maintenance updates.

In response, GitLab stopped building and releasing packages for Ubuntu 14.04 with version 11.10.4
Issue: https://gitlab.com/gitlab-org/omnibus-gitlab/issues/4234
Merge Request: https://gitlab.com/gitlab-org/omnibus-gitlab/merge_requests/3192

I recommend either upgrading or migrating to a newer, currently supported OS like Ubuntu 16.04 to continue receiving GitLab and OS-level updates.

If you have any questions or issues updating, please don’t hesitate to reach out

All the best,
Greg

Hi @gitlab-greg

Ah that explains why. Thanks for the response.

I’ll try to upgrade mine to 16.04

Regards,
Fairuz