Not allowed to force push code to a protected branch

On my project plainsailingweb/copyvisionservicing, I have a branch called admin_tables_development. It is checked out to an Amazon Lightsail ubuntu server. I have finished making changes and have checked everything into the local repository on that server. But I can’t push that code into GitLab.
I get an error that allowed to force push code to a protected branch on the project.

I didn’t think I had that branch protected.

But even when I do protect it and within GitLab and give myself permission.

In Settings->Repository, for that branch I have allowed Maintainers to merge, my deploy key to push and I am allowed to force push.
I get the same error if I select “Unprotect”.
What am I doing wrong?
I just want to be able to check my code into the GitLab repository.
I am using
I have read as much documentation as I can, and tried several times with and without the branch protected.
Please can someone suggest what I should try next.

If you don’t need to protect that branch you don’t need to enable Branch protection.

Make sure that you have enabled write access for that Deploy key.

Thanks for replying Peter.
I have been having another look this morning.

I only have branch “main” as a protected branch:

My deploy key can write to the repository:

I have previously written to this repository, but that was to the branch main, before the first version of the software was put into production.

SpinupWP is where I have linked GitLab to the Lightsail server.

It was created from an SSH Clone of the repository and branch admin_tables_development.

I’ve been looking at the folder git on the server. Should the file description have anything in it other than “Unnamed repository”, or the branches folder contain anything?

As far as I understand the deploy key is per repository. Is there anything that would limit its write capabilities down to a branch?

I am not familiar with SpinupWP so I can’t help there. Only in general, make sure that it is indeed using that deploy key when doing git operations. There should be a private part of the key configured somewhere.