Omnibus package upgrade to 8.0 fails

Currently I run GitLab 7 which runs perfect, but of course I would like to run the latest GitLab version. Earlier I download the VirtualMachine file and from that i updated to each new version.

Today I wanted to upgrade to 8.0 but I get the following errors:

Starting Chef Client, version 12.4.1
resolving cookbooks for run list: [“gitlab”]
Synchronizing Cookbooks:

  • runit
  • package
  • gitlab
    Compiling Cookbooks…
    Recipe: gitlab::default
  • directory[/etc/gitlab] action create (up to date)
    [2015-09-22T22:03:15+02:00] WARN: Cloning resource attributes for directory[/var/opt/gitlab] from prior resource (CHEF-3694)
    [2015-09-22T22:03:15+02:00] WARN: Previous directory[/var/opt/gitlab]: /opt/gitlab/embedded/cookbooks/cache/cookbooks/gitlab/recipes/default.rb:43:in from_file' [2015-09-22T22:03:15+02:00] WARN: Current directory[/var/opt/gitlab]: /opt/gitlab/embedded/cookbooks/cache/cookbooks/gitlab/recipes/users.rb:24:in from_file’

Recipe Compile Error in /opt/gitlab/embedded/cookbooks/cache/cookbooks/gitlab/recipes/default.rb


No resource, method, or local variable named ci_service' for Chef::Recipe “gitlab-ci_disable”’

Cookbook Trace:

/opt/gitlab/embedded/cookbooks/cache/cookbooks/gitlab/recipes/gitlab-ci_disable.rb:69:in `from_file'
/opt/gitlab/embedded/cookbooks/cache/cookbooks/gitlab/recipes/default.rb:74:in `from_file'

Relevant File Content:


62: service ci_service do
63: action :stop
64: end
66: include_recipe “gitlab::#{ci_service}_disable”
67: end
69>> if node[“gitlab”][ci_service][“enable”]
70: node.override[“gitlab”][ci_service][“enable”] = false
71: end
73: end
75: if node[“gitlab”][‘gitlab-ci’][“enable”]
76: node.override[“gitlab”][‘gitlab-ci’][“enable”] = false
77: end

Running handlers:
[2015-09-22T22:03:15+02:00] ERROR: Running exception handlers
Running handlers complete
[2015-09-22T22:03:15+02:00] ERROR: Exception handlers complete
Chef Client failed. 0 resources updated in 2.544383345 seconds
[2015-09-22T22:03:16+02:00] FATAL: Stacktrace dumped to /opt/gitlab/embedded/cookbooks/cache/chef-stacktrace.out
[2015-09-22T22:03:16+02:00] ERROR: No resource, method, or local variable named ci_service' for Chef::Recipe “gitlab-ci_disable”’
[2015-09-22T22:03:17+02:00] FATAL: Chef::Exceptions::ChildConvergeError: Chef run process exited unsuccessfully (exit code 1)

The command I ran was:

apt-get update && apt-get dist-upgrade

Is this a common problem? How to solve this? I had GitLab CI installed earlier.

OK solved it. I commented all the ci settings and reconfigured GitLab