Upgrading to Latest GitLab Fails on Omnibus System with Ubuntu 18.04

Hi I cant seem to upgrade my gitlab setup from 12.06 EE to 12.10 EE.

its been a while since I have upgraded my setup… i tried to upgrade today but theres this error that I just cant figure out.

root@git:/opt/gitlab# gitlab-ctl reconfigure
Starting Chef Client, version 14.13.11
resolving cookbooks for run list: ["gitlab-ee"]
Synchronizing Cookbooks:
  - gitlab-ee (0.0.1)
  - package (0.1.0)
  - gitlab (0.0.1)
  - consul (0.1.0)
  - repmgr (0.1.0)
  - runit (4.3.0)
  - postgresql (0.1.0)
  - redis (0.1.0)
  - monitoring (0.1.0)
  - registry (0.1.0)
  - gitaly (0.1.0)
  - mattermost (0.1.0)
  - praefect (0.1.0)
  - letsencrypt (0.1.0)
  - nginx (0.1.0)
  - acme (4.0.0)
  - crond (0.1.0)
Installing Cookbook Gems:
Compiling Cookbooks...

Recipe Compile Error in /opt/gitlab/embedded/cookbooks/cache/cookbooks/runit/attributes/default.rb.dpkg-new

could not find filename for attribute default.rb.dpkg-new in cookbook runit

System Info:
ruby=ruby 2.6.3p62 (2019-04-16 revision 67580) [x86_64-linux]

Running handlers:
There was an error running gitlab-ctl reconfigure:

could not find filename for attribute default.rb.dpkg-new in cookbook runit

Running handlers complete
Chef Client failed. 0 resources updated in 04 seconds


There is no version called “12.06”. If you mean 12.0.6, my suggestion would be to first upgrade to the last patch release of the 12.0 series, that is 12.0.12, and then possibly go to 12.1 (something happened to the versions around 12.0.x).

Hi @grove my apologies for the mistake… I was quite tired at that time trying to solve the problem. I was still not able to resolve… The correct version that I currently have is 12.6.0-ee… I am trying to upgrade to latest but failed.

What commands do you try, and what is the output? (Please give the complete output)

Hi @grove thanks for the quick reply… Actually, my setup has this gitlab-ee and gitlab-ce installed via ubuntu apt package manager (omnibus) because I upgraded to EE long time ago… Then i just realized I needed to upgrade my installation because it’s getting out of date already since my last upgrade… But before doing so, I have executed gitlab-ctl reconfigure and got this error:

i think this is what is making the upgrade fail…

PS: I have tried to just proceed ugrading via apt update gitlab-ee regardless, but I got this error:

Then the gitlab-ctl command gets broken gitlab-ctl: command not found

It has been my routine to make snapshots before upgrading. so, all failed upgrades can be reverted back to its last original working state…

NEVER post text as images!

In most cases it’s harder, and the images are unsearchable, unusable for screen readers, and impossible to copy text in replies. (I believe I had another argument the last time I wrote such a complaint here).

I’ve looked at the images anyway, and I’m really not familiar with that kind of errors. Hopefully you can find someone better to provide help, but if I had to try something (with the risk of breaking things even worse), I would delete the (probably all) .dpkg-new (if you had used a text-based pastebin I could - and would - have copied the filename, to provide more precision) that chef complains about. Being called .dpkg-newindicates that it belongs to a new version, and your upgrade failed, so it might just be in the way. But note that this is a guess, and doing it risks breaking your stuff even more than it is.

Hi @grove my apologies for the use of images, will copy as text next time…

I understand… I think my last upgrade might have indeed failed… In that case, I might need to have a complete reinstallation of gitlab in a separate server and just migrate… I find it too bloody to solve this issue than to have a complete reinstallation… anyways thank you for your guidance!

cheers, mate! :slight_smile: