Omnibus Upgrade from 13.11.4 causing the issue PG::UndefinedObject: ERROR: constraint "web_hook_logs_pkey"

Hi Team,
When i run apt update and apt upgrade on our Ubuntu to upgrade from version 13.11.4 causing the issue with the error message

Caused by:

PG::UndefinedObject: ERROR: constraint “web_hook_logs_pkey” for table “web_hook_logs_archived” does not exist

/opt/gitlab/embedded/service/gitlab-rails/lib/gitlab/database/partitioning/replace_table.rb:32:in `execute’

/opt/gitlab/embedded/service/gitlab-rails/lib/gitlab/database/partitioning/replace_table.rb:27:in `perform’

I tried to run gitlab-ctl reconfigure but getting the same error.
Please let me know how I can it.
Thank you.

Resolved it by running

ALTER TABLE "web_hook_logs" DROP constraint idx_112871_primary;
DROP INDEX CONCURRENTLY web_hook_logs_pkey;
CREATE UNIQUE INDEX CONCURRENTLY web_hook_logs_pkey ON web_hook_logs (id);
ALTER TABLE web_hook_logs ADD PRIMARY KEY USING INDEX web_hook_logs_pkey;
gitlab-ctl reconfigure
gitlab-ctl restart
apt update
apt upgrade```