Ubuntu server 20.04 on raspberry pi: Unable to locate package gitlab-ce

Hi!
I’m trying to install gitlab-ce on my raspberry pi 3 (as a crash test before installing it on my rpi 4).

Here are the steps I followed:

I got: E: Unable to locate package gitlab-ce

I have a fresh install of ubuntu server 20.04 on a raspberry pi 3 with : Kernel: 5.4.0-1013-raspi aarch64 bits: 64, System: Raspberry Pi 3 Model B Rev 1.2, System: Raspberry Pi 3 Model B Rev 1.2, CPU: arch: ARMv8.

Gitlab for ubuntu focal fossa was released so it’s supposed to work. I tried this: https://gitlab.com/gitlab-org/omnibus-gitlab/-/issues/5176#note_352351367 but got the same error.

Thanks for your help

Hello @Izaya,

The RPi repository is here: https://packages.gitlab.com/gitlab/raspberry-pi2

Installation instructions:

What might be important for you is the warning that you may find there:
" Raspberry Pi 4 with at least 4GB is recommended. Only 32bit ( armhf ) is supported at this point. 64 bit ( aarch64 ) is on its way."

Best Regards,
Łukasz Korbasiewicz
Support Engineer
GitLab, Inc.

1 Like

Thank you for this fast answer. I thought I need the Ubuntu package because my OS isn’t Raspbian.

I tried it on the rpi 3 but it gave me the same error. Perhaps because it’s a rpi 64 bits (aarch64) and, as you pointed out, it’s not currently supported.
So I will wait for this release.

Have a nice day!
Izaya

1 Like