Problem with container registry

Hi everyone!
I installed gitlab-ee by docker image, its working all right. Then i tried to configure container registry, did everything with ssl certificate, and im getting here v2/_catalog this:

{"errors":[{"code":"UNAUTHORIZED","message":"authentication required","detail":[{"Type":"registry","Class":"","Name":"catalog","Action":"*"}]}]}

When i try to use docker login it asks login and password but then im getting
Error response from daemon: Get "": received unexpected HTTP status: 503 Service Unavailable

I tried everything but cant fix it, can you please help me?

I also started a gitlab instance from the docker gitlab/gitlab-ee and cannot see the container registry. How does one make the container registry visible? When running the docker image does the container registry port need to be exposed? I am using gitlab v16.5.1-ee.

UPDATE: Nevermind, I did enable the registry and published the port and it appeared via my docker compose file:

version: '3.6'
    image: 'gitlab/gitlab-ee:latest'
    container_name: 'gitlab-8001'
    restart: always
    hostname: ''
        external_url ''
        registry_external_url ''
        registry['enable'] = true
        registry_nginx['redirect_http_to_https'] = true
        registry_nginx['listen_port'] = 5005
      - '8001:8001'
      - '5005:5005'
1 Like