Gitlab & Docker Registry inside a docker container

Hey folks!

I am running GitLab *in a docker container" following the official guides.
I am also trying to use the gitlab registry and push my containers into it.

I can see that the registry is enabled in the webpanel. I can also see that there is no containers on the repo.

I can login to the registry, but pushing a container always fails with a timeout because the URL for the docker registry API seems to be non working.

There is so many config options with various ports in the gitlab.rb that I really do not understand what to configure (which options to uncomment and alter).
I tried following the official guides, but that simply does not work.

Do I need to proxy the registry API via my nginx proxy somehow? I tried doing that, but I am not sure I got the right port. Is 4567 the right port or 5000?

docker login does so over port 5005 but docker push seems to do so over port 5000. And then there is this ominous port 4567 of the registry.

One odd bit in trying to get this to run: I never had a succeeding build, when trying to make this work, but one time suddenly a container appeared in the registry. I then checked the build log which told me the push failed again. So I am unsure what fluke that was …

Can anyone explain to me how to do this? Again, I am running EVERYTHING INSIDE A DOCKER CONTAINER. No omnibus or the likes.

Thanks a lot in advance.

P.S. I’ll more than hapily provide any required materials to troubleshoot this, but it feels like I tried every possible iteration of the configurations and there is no point in trying to post them all … it seems like there should be a standard, straightforward way to do this and it’s just not documented right.