Reducing repo size

We’re working on a game and we’re storing the code and assets in a GitLab repo. Today we got this message on a push: GitLab: Your push to this repository would cause it to exceed the size limit of 11 GB so it has been rejected. Please contact your GitLab administrator for more information.

I removed 4GB of old assets and tried to push again, but I got the same message.

I’ve also tried running housekeeping on the project but it said that housekeeping has already been ran in the last 60 minutes, even though nobody did that (I’m the only master on the project).

On I also deleted a branch that held 1GB of assets, the repo size didn’t go down. The branch was not merged into any other branches.

What is the correct way to remove old files from the repo and reduce its size so we can continue to push to the repo?

I’m having a similar problem with my GitLab repository.
Despite only having pushed relatively small files in the last few days, this morning when I tried to push a commit I was greeted with
GitLab: Your push has been rejected, because this repository has exceeded its size limit of 10 GB by 7 GB. Please contact your GitLab administrator for more information. fatal: The remote end hung up unexpectedly
I’ve tried pushing from two different remotes and both are giving me the same message. As in the OP’s case, I’ve been deleting some of the bigger files in my repository but I’m greeted with the same message when attempting to push.
I’ve found some places recommending the use of git filter-branch, but these come with warnings as to the consequences so I’m somewhat loathe to use this method…
Any help with this issue would be greatly appreciated!