(SOLVED) GitLab Specific Runner does not trigger automatically

runner
ci

#1

Hey folks,

The Build

I’m trying to figure out what exactly I’m doing wrong with my configuration. So, here’s the run down:

  • GitLab Group Project (on https://gitlab.com/ for the URL)
  • GitLab Runner OS: Fedora 28
  • GitLab Runner Running via DigitalOcean
  • GitLab Version: 11.8.0 and 11.6.0 (I’ve tried both)

TOML Configuration

concurrent = 1
check_interval = 0

[session_server]
  session_timeout = 1800

[[runners]]
  name = "XXXX"
  url = "https://gitlab.com/"
  token = "XXXXXXXXXXXXX"
  executor = "shell"
  [runners.cache]
    [runners.cache.s3]
    [runners.cache.gcs]

On Gitlab

The Runner on GitLab shows it’s not active:
Screenshot%20from%202019-03-16%2022-12-47

Things I’ve done

  • Checked the firewall, it was my original guess
  • Tried running debug mode with gitlab-runner (this actually works! but after killing it, nothing gets triggered, so I can manually trigger them)
  • Reboot server
  • Restart gitlab-runner service
  • Re-registered gitlab-runner
  • Uninstalled and Installed gitlab-runner
  • Tried different versions of gitlab-runner
  • Verified that config.toml file is destroyed when registering and is then recreated
  • Verified the version of gitlab-runner is compatible with my OS
  • Cleared Runner Caches and Ran Pipeline
  • Checked the logs, which I get this:
Mar 17 02:43:45 gitlab-runner-name gitlab-runner[8344]: WARNING: Checking for jobs... failed                runner=XXXXXXXX status=couldn't execute POST against https://gitlab.com/api/v4/jobs/request: Post https://gitlab.com/api/v4/jobs/request: dial tcp 35.231.145.151:443: connect: permission denied

This above error, I’ve googled and tried to figure out what I’m doing wrong. Do I need some sort of token to get this to work then? And, why does the gitlab-runner work when I force a run using gitlab-runner run or gitlab-runner verify?

The problem

  • Jobs are getting stuck, but weirdly enough, jobs run when I force them with the gitlab-runner run command

Please assist.

Thanks,

-David V


#2

I’m going to go ahead and close this, I decided to keep moving and I just had an active console that had gitlab-runner run running. My pipe broke to my server and killed the service. Somehow, it works now, no idea why. But hey, good enough for me.