There are no active runners online, no runners for the protected branch, or no runners that match all of the job's tags: sree2sree1

HI forum,

I am new to GITLab infact new to devops also, Need help on below thing.
I have created a project sample project in my company and set up local runner and started at local system. Below is the image which shows my local runner. and
image
It configurations are.


And my Yml scrit i written is very simple.
test:
#stage: Test
#rules:
#- if: $CI_PIPELINE_SOURCE == “schedule”
tags:
- sree2
- sree1
script:
- echo “hello1”
With the above things i am getting runner is not active. Need help on this. i have gone through the topics which are related but not solved my problem . Do i need to do anything extra in my case

The screenshot with the runner has a warning icon next to it. The GitLab runner is probably not running or cannot reach the GitLab server. I’d suggest looking into the runner logs, and check whether the service is running.

Thanks michi for replay. But I tried to do GitLabRunner stop and GitLabRunner start upload the imagefor reference , still is showing the not connected mark.

.
Fowwed the below procedure for runner activation let m eknow anything else what to do.

  1. downloaded GITLAb runner from net .
  2. Copy pasted in GITLab folder and ran below commands .
    GitLabrunner.exe status
    GitLabrunner.exe start
  3. After this Login to GitLab server and in CI/D settings section provided the above details which already shared before. Any thing else I missed here. Please et me know.
    Note: Not added SSH key in gitlab server for this runner .

Thanks for the details. I do not have experience debugging GitLab Runner on Windows, but I have found this issue where it says to run gitlab-runner verify so that the runner tries to connect to the GitLab server. In the screenshot above, it says that the runner never contacted the server yet.

Another comment in the issue mentions that file permissions for config.toml might be the problem. Suggest trying that too.

I found the issue. Here which ever PC or system I created the rnner is already using by some ther project .
Hence it is saying not running . How do I make this runner to run both the projects. I have enabled shared runner button on left but not enabling may be that belongs tp gitlab shared runners . Please help on this