[Solved]How to resolve duplicate packages due to aborted yum update on centos6

This morning I went to update gitlab-ce using yum on our CetnOS6 server from 8.8.4 to 8.8.5.

Unfortunately about halfway through the first of the two install steps (i.e. the bit that says something like Updating gitlabx.x.x. [### ] 1/2 I accidentally mashed the pause-break key on my keyboard.
The result being that yum stopped. I tried several things - being a *nix amateur I started out with retrying the yum command - which told me yum was locked. So I found the yum PID and tried the kill command - no luck. Until I found fg to foreground the yum job again.

Thought I had resolved things then, using yum-complete-transaction which found the transaction and appeared initially to be resuming the update. But this said it was complete as soon as it finished listed the dependencies it resolved and the transaction summary

So I tried yum-complete-transaction --cleanup-only which said it cleaned up a transaction journal.

Now, trying yum update gitlab-ce says 8.8.4 will be updated and 8.8.5 will be an update but the subsequent transaction check finds 8.8.5 is already installed and then stops.

package-cleanup --dupes lists 8.8.5 and 8.8.4. The gitlab control panel still shows 8.8.4 and that I need to update ASAP.

I am now not sure how updated or not gitlab is and how I can get yum to complete the update… how can I do this?

EDIT: Just ran `gitlab-rake gitlab:env:info which reports the gitlab version to be 8.8.5… totally confused now!

System information
Current User: git
Using RVM: no
Ruby Version: 2.1.8p440
Gem Version: 2.5.1
Bundler Version:1.10.6
Rake Version: 10.5.0
Sidekiq Version:4.1.2

GitLab information
Version: 8.8.5
Revision: 68cd138
Directory: /opt/gitlab/embedded/service/gitlab-rails
DB Adapter: postgresql
URL: http://gitlab.$our-domain.com
HTTP Clone URL: http://gitlab.$our-domain.com/some-group/some-project.git
SSH Clone URL: git@$our-domain:some-group/some-project.git
Using LDAP: yes
Using Omniauth: no

GitLab Shell
Version: 2.7.2
Repositories: /var/opt/gitlab/git-data/repositories
Hooks: /opt/gitlab/embedded/service/gitlab-shell/hooks/
Git: /opt/gitlab/embedded/bin/git

As the gitlab-rak gitlab:env:info command returns 8.8.5, could it be that I just need to do a gitlab-ctl upgrade and a gitlab-ctl reconfigure, maybe a gitlab-ctl restart?

Over on stack overflow rpm -e --justdb ${exact_package} has been suggested (where exact package is the 8.8.5 package). I am not familiar with thus command so shall be researching before using - any advice on this idea also welcome though!

So I tested the rpm command with rpm -evv --test --justdb gitlab-ce-8.8.5 where 8.8.5 is the newer package I have been trying to upgrade to (not from). This showed it just removes the RPM database entries for the new gitlab version.

Hence I then ran the non-test version of the command: rpm -e --justdb gitlab-ce-8.8.5.

When I subsequently ran the yum command to retry the update as normal, it checked with the RPM DB and now saw only the older 8.8.4 entry and proceeded to update to 8.8.5 as it normally would. Yay!