GitLab yum update hanging/long time in "Running Transaction" (CentOS)

I was wondering if anyone has encountered this issue. I acknowledge this is a yum issue but I was wondering if anyone else has seen it. GitLab yum update is inconsistent during yum “Running Transaction.” It seems to take longer with each update (or it varies but it’s always too long. Like, 20 minutes or more) We have a large GitLab instance, but this is not happening during GitLab operations, only yum/rpm. Running on a test server only takes a few minutes.
Last night I had to kill the yum transaction, as it was stuck for almost an hour. I had no way of knowing if it was taking long or hung (rpm verbosity does not show any output during the step)
The odd thing is that I’ve done lots of yum updates for other packages on this server and none of them have encountered this issue. I guess that means we might have yum/rpm database corruption in direct regards to the GitLab package? I will be trying a full yum / rpm repair before our next try. (and probably a strace)
If anyone has input, it would be appreciated. I don’t want to be stuck with a GitLab instance I can’t update!

We solved this problem by increasing the memory on our VM. Turns out it was the size of our instance combined with low memory. I ran a “top” during “Running transaction” and among other things, saw a CPU-intensive “gzip” begin performed. That would need the extra mem space, given our amount of data.

1 Like