SOLVED: Kubernetes: Prometheus uninstallation failed

Dear GitLab Community.

I have installed prometheus in a kubernetes cluster using gitlab and tried to uninstall it some time ago and am stuck now with a failing uninstall.
I removed everything in kubernetes connected to prometheus i could find, but gitlab still thinks, that it is installed.
How does gitlab determine, that prometheus is installed and how can i clean this up?

Thanks in advance

I solved it by removing the information about the previous prometheus installation from the gitlab database.
For this i connected to the database via
sudo -u gitlab-psql /opt/gitlab/embedded/bin/psql -h /var/opt/gitlab/postgresql gitlabhq_production

As i had only one prometheus installation and one cluster, i could delete it with
delete from clusters_applications_prometheus;

Afterwards i could install prometheus again and it is running now. :slight_smile:

Hey @daniel3, could you please verify if you have uninstalled it for project level/group level clusters? Here’s some more info about this

Hi @dsumenkovic , thanks for the answer, it is a group level cluster.

Thank you for updating the solution! It will definitely help others who experience the same trouble :slight_smile: