[SOLVED] Server Migration results in Error 500

At first: Thank you for your help!

I’ve used GitLab for quiet some time, and it’s great. I’ve recently moved my server to a new one, into a datacenter, but the migration wasn’t successful, even if evey check i’ve run yielded in no result which could explain the Error 500 i am recieving after logging in to the new server.

I will provide whatever logs or information are needed, but since i don’t have a clue where to begin, please ask.

What i’ve tried:
purging and reinstalling Gitlab-CE(Omnibus)
reconfiguring and restarting
run: gitlab-rails runner “Project.where(mirror: false).where.not(import_url: nil).each { |p|p.import_data.destroy if p.import_data }” (as suggested by some forum entry)
run: gitlab-rake db:migrate:status
run: gitlab-rake gitlab:app:check

None of the above helped me finding out what went wrong.

Some general information:

Webserver: Apache 2
Ubuntu 16.04 LTS

New Instance:
Gitlab 9.4.0 (Latest)(Omnibus)

Old Instance:
Gitlab 9.4.0 (Latest)(Omnibus)
(older Backups are available)

I know, this isn’t much, but i’m out of ideas.

I’m not quiet sure what solved this error in the end, but after several retries, i’ve got my gitlab back online.

I guess i forgot to back up the
/etc/gitlab/gitlab-secrets.json file, which is used for 2FA (and other stuff)