[Solved] Trouble while trying to install Gitlab under Apache Subdomain

EDIT : Ok, my bad, the worst error happened.

I forgot to clean cache. FML.

Thanks anyways x)

Broken english incoming

Hi everyone,

I recently wanted to install Gitlab on my Debian 9 server.
This one runs an Apache server.

I followed the guide to set it up properly, then I noticed that GL brings an embedded nginx server on its own, so I had to tweak a bit the gitlab.rb file :

external_url 'http://XXX'
gitlab_workhorse['listen_network'] = "tcp"
gitlab_workhorse['listen_addr'] = ""
gitlab_workhorse['auth_backend'] = "http://localhost:8080"

Then I ran gitlab-ctl reconfigure to save this configuration, and I tried to go for the Apache virtualhost.

I grabbed the sweet premade VH file for my Apache version ( gitlab-omnibus-apache24.conf), and I edited it to make sure it was going to the good URI :

ServerName XXX
ProxyPassReverse http://XXX/
ErrorLog /var/log/apache2/XXX_error.log
CustomLog /var/log/apache2/XXX_forwarded.log common_forwarded
CustomLog /var/log/apache2/XXX_access.log combined env=!dontlog
CustomLog /var/log/apache2/XXX.log combined

The following a2ensite gitlab.conf + systemctl reload apache2 goes silent, so it looks like everything is ok. But when I try to access http://XXX, I keep falling for the Apache2 default page.

Does anyone have a hint about why this happens ? Did I missed something on configuration ?