[Solved] Upgrade 7.8.2 to 7.9.4 failed

Hi all,

I just tried to upgrade gitlab CE from 7.8.2 to 7.9.4, but I get at the end the nginx service down.

Infos :
OS : CentOS 6.6
Package : Omnibus rpm

Operations done :

  1. Download the new package gitlab-7.9.4_omnibus.1-1.el6.x86_64.rpm
  2. gitlab-ctl stop
  3. rpm -Uvh gitlab-7.9.4_omnibus.1-1.el6.x86_64.rpm
  4. gitlab-ctl reconfigure
  5. gitlab-ctl start

With gitlab-ctl status, I get :
run: logrotate: (pid 878) 1655s; run: log: (pid 873) 1655s
down: nginx
run: postgresql: (pid 883) 1655s; run: log: (pid 879) 1655s
run: redis: (pid 881) 1655s; run: log: (pid 875) 1655s
run: sidekiq: (pid 876) 1655s; run: log: (pid 872) 1655s
run: unicorn: (pid 877) 1655s; run: log: (pid 871) 1655s

An idea ?
Thanks for your help

Well, there’s your problem. It says that nginx is down. Have you tried starting it, @biowan?

@biowan what do the logs say?
I assume nginx encountered an error during the startup.
Make sure no other process is listening on port 80.

Hi,

Sorry guys. Thanks for your anwser.

2015/04/17 10:45:58 [emerg] 7464#0: BIO_new_file("/etc/gitlab/ssl/gitlab.mydomain.crt") failed (SSL: error:02001002:system library:fopen:No such file or directory:fopen('/etc/gitlab/ssl/gitlab.mydomain.crt','r') error:2006D080:BIO routines:BIO_new_file:no such file)

So, my problem is solved. Because the upgrade had changed the nginx config file (gitlab-http.conf) on parameters ssl_certificate and ssl_certificate_key. I just reset the right values and it was done.

Thanks.