SourceTree: cannot clone, password rejected

Probably not a GitLab issue but I would really appreciate if anyone could help me!
I am connecting over SSH and have created a personal access token, I can view the remote repos but when I try to clone I get a Password required dialog. I have tried both my password and the personal access token but the dialog immediately pops up again without any error.
Any suggestions?

Hi Johan,

Have you uploaded your public key?

Here is what I did to clone to/push from SourceTree:

You need to create a new pair of SSH-2 RSA keys:

  1. In SourceTree, go to Tools > Create or Import SSH Keys .
  2. Click Generate to generate a public and a private key.
  3. Save both keys in files with .ppk extension.
  4. Select and copy the text from the Public key for pasting… box to the clipboard.
  5. In GitLab, go to Profile Settings > SSH Keys and paste the contents of the clipboard to the Key box and click Add Key .
  6. In SourceTree, go to Tools > Launch SSH Agent . It starts Pageant (PuTTy Authentication Agent) , which you can find in the system tray (among hidden icons on the right-hand side of the taskbar). Open it, click Add Key and select the just generated private key.

Hi Alexk, thanks for your reply. There is no Tools menu in SourceTree on macOS:

However, SoureTree points to the correct pub key in Settings/Accounts
I can see my repos in remote browser but when I clone I never get past the “password required” dialog, same thing if I add the git url in “clone from url”

This is now solved. It required the ssh passphrase which I had not tried
I could now clone but have to enter the password several times
I now get stuck on git-lfs instead
I get stuck in the next step related to git lfs and public key:

Got this after successfully cloning

batch request: Permission denied (publickey).: exit status 255error: failed to fetch some objects from ‘

and this when checking out another branch

Downloading applications/synktest/assets/audio/audio_test_8sec_48khz.aac (8.4 KB)

Error downloading object: applications/synktest/assets/audio/audio_test_8sec_48khz.aac (5c89c5e): Smudge error: Error downloading applications/synktest/assets/audio/audio_test_8sec_48khz.aac (5c89c5e4c943655d25c6fd4c5701ec0b5403a3675fc895db24dccc55a0ad1a7d): batch request: Permission denied (publickey).: exit status 255

Errors logged to /Users/DinahmoeStudio/Documents/gitlab/dmafjs-video/.git/lfs/logs/20190926T091057.42028.log

Use git lfs logs last to view the log.

error: external filter ‘git-lfs smudge – %f’ failed 2

error: external filter ‘git-lfs smudge – %f’ failed

fatal: applications/synktest/assets/audio/audio_test_8sec_48khz.aac: smudge filter lfs failed

the error log doesn’t give any additional information

Any ideas?
the error log doesn’t give any additional information

Any ideas?