SSH Fail! Fingerprint has already been taken

I see at least a couple of other issues for this error, but no clear resolution.

I created an SSH RSA key and am trying to add it to my Gitlab account so I can version control local files and push them into Gitlab repositories. However I get the following error:

The form contains the following errors:

*** Fingerprint has already been taken**
*** Fingerprint cannot be generated**

I tried the advice of some other articles and Stackoverflow threads which say to create another files and call it or something of the sort. This also creates an alternative id_rsa file in the .ssh directory.

Still the same errors.
I deleted the SSH key that I was previously using in the Gitlab account because it was also not working.
I have followed the Gitlab instructions for generating and SSH key.

Can someone please help me fix this issue?

I have exactly the same problem. When connecting DeployHQ to GitLab, DeployHQ generates an SSH key. I am supposed to add that SSH key to my GitLab account. When I do that, I get this error: “Fingerprint has already been taken!”.

I cannot generate a new key at DeployHQ: it just generates one, and always the same one, for your account. When GitLab does not let me add it, I am stuck. What to do? How could I resolve this?

I have already tried removing all CR LF characters (non were present) and trailing spaces (non were present).

I was able to solve my particular issue because of an error which returned that the file path could not be found for my id_rsa file.

I modified the filepath in .ssh/config and was able to correctly link my to the private SSH key in id_rsa.