SSH Not Working

Since the last deploy git commands using SSH are completely down – anybody else experiencing this?

I’m having the same issue.

GitLab: API is not accessible

I was pushing just fine prior to the deployment.

1 Like

Same @kherge Googling points to a symlink issue. No idea how accurate that is as it’s not my job to fix this but man is someone in the shit tomorrow. If thats the case it could be a tough fix depending on their architechture. This company is way too big to push deployments that aren’t well tested.

At the least where was the EMAIL to let us know about maintenance. This is affecting a major deployment of my own

Having problems also. After today’s deployment I can’t push or pull. The error says “Permission denied (publickey).
fatal: Could not read from remote repository.”. I have tripple checked and the right SSH key is added and it worked for this repo more that a year already from the same machine with the same SSH key (

1 Like

Works fine now. Thanks for resolving that.

It’s still not working for me over SSH, but I was able to push over HTTPS.

Since I have 2FA enabled, this is a pain to use.

Edit: I cloned the repository on a new machine and that seems to work. I don’t have access to my other machine at the moment, so either GitLab fixed the issue or it has something to do with the remote settings for the repository on the other machine.

Edit 2: GitLab on Twitter has responded to me. They said that they have fixed it and gave me a link to their issue tracker.

Same here:

Pushing to
GitLab: API is not accessible
fatal: Could not read from remote repository.

Hello devgeek. Sorry for bothering but please how did you resolve this issue? I just started using gitlab and I am having the same problem. I have checked my key. It is added to my gitlab account. The same key exists on the machine I am pushing from (It is actually the same machine). Thanks