SSL certificate problem: unable to get local issuer certificate

I’d like to use Git LFS, but unfortunately, it won’t work with SSH atm, so I’m trying to use HTTPS instead.

Unfortunately, I’ve been trying for hours, but I keep getting the following error:

SSL certificate problem: unable to get local issuer certificate.

I’ve looked through many posts on google, and tried to export the Gitlab SSL certificate from my browser and pasting it into my ca-bundle.crt file under C:\Program Files\Git\mingw64\ssl\certs (I’m using Windows + Sourcetree) as well as ensuring the Git sslCAInfo configuration variable is pointing to the right file, but I’m having absolutely no luck.

Perhaps, I’m not exporting the right certificate? Anyways, any help would be much appreciated.

Thanks,

1 Like

I’m having the same issue. Did you find a fix? At this point I’m just trying to find out how to turn off SSL verify like command line Git.

I have the same problem. I fixed it momentarily adding the next line: git config --global http.sslverify true but this doesn’t fix the certificate error en the gitlab server

Same problem here.

I use a commercial certificate (from DigiCert) and I run the GitLab web-frontend over https. But my clients says “SSL certificate problem: unable to get local issuer certificate”.

I have tried to place the root cert + intermidiate cert in the folder /etc/gitlab/trusted-certs/ but with no success. I get this when I run “reconfigure”.

 * ruby_block[Move existing certs and link to /opt/gitlab/embedded/ssl/certs] action run
 * Moving existing certificates found in /opt/gitlab/embedded/ssl/certs
 * Symlinking existing certificates found in /etc/gitlab/trusted-certs
 Skipping /etc/gitlab/trusted-certs/terena_root.cer.
 Skipping /etc/gitlab/trusted-certs/terena_inte.cer.

I have now solved my problem.

I had mixed up the sequence of the certificates in the /etc/gitlab/ssl/server.example.crt file.

The sequence in the file must follow:

top: server-cert
middle: intermediate-cert
bottom: root-cert

1 Like