The artifacts uploading is not supported in this executor

I’m completely new to creating builds with GitLab, I’m trying it out for the first time.

I have a PHP project which requires some packages installed, so I’ve setup a build file to run ‘composer update’ which is working fine.

I assumed that once the build was complete there would be an option somewhere in the builds screen to download an archive of the build, but I couldn’t see anything. I’ve tried to do some research but can’t seem to find a concrete answer on how to do this. However, based on what I’ve read I’ve tried to put together something myself; here’s my .yml file;


  • build

stage: build
- “composer update”
- “zip -r *”
- “mv /root/”
name: “$CI_BUILD_NAME”

The build runs and succeeds, but I see an error “The artifacts uploading is not supported in this executor”, but I have no idea why and wondered if someone could help?

I’m self hosting gitlab on an internal server and have installed a runner to use SSH.

What OS is your Runner on? Looks like certain features may not be supported in some shells.

You might try reading this QA from stack overflow: