Trouble getting GitLab Kubernetes agent to work

I am struggling to get the GitLab agent working. I am installing GitLab CE v16.4.1 to a Kubernetes 1.28 cluster on my home lab using the helm chart. I have tried like 5 times, and I keep running into the same problem.

Following the installation instructions here and here, I am able to get the agent deployed and bound to GitLab.

I setup a simple config for both user access and ci access in one project:

And the agent shows as connected:

When I go to environments configuration to try to bind the agent to my environment:

I get a 401 unauthorized error upon selecting the agent:

Additionally, when I try to run kubectl commands in a pipeline (this pipeline):

  stage: deploy
    name: bitnami/kubectl:latest
    entrypoint: ['']
  script: |
    kubectl config get-contexts
    #kubectl config use-context
    kubectl get pod -A

This is what I get in that stage:

When trying to run kubectl get pod -A, I would expect it to print the running pods, but instead I get this error:

Error from server (Forbidden): pods is forbidden: User "system:serviceaccount:default:default" cannot list resource "pods" in API group "" at the cluster scope

I tried installing the helm chart with and without service account creation, specifying my own account with high privileges. Nothing worked. Any help would be appreciated, I am kind of stuck on this. Thank you!