Ubuntu 22.04LTS: Unable to upgrade: gitlab-ce is already the newest version (13.12.15-ce.0)

Good morning,
I’m unable to upgrade from 13.12.15 cause apt message:
gitlab-ce is already the newest version (13.12.15-ce.0)

Steps to reproduce:

  1. having Ubuntu 16.04LTS and GitLab-CE 13.12.15
  2. upgrade Ubuntu from 16.04LTS to 20.04LTS
  3. upgrade Ubuntu from 20.04LTS to 22.04LTS
  4. sudo apt-get update && apt-get upgrade gitlab-ce

What is the current bug behavior?
In apt it will say gitlab-ce is already the newest version (13.12.15-ce.0)

What is the expected correct behavior?
Upgrade GitLab to v14

Environment details:
GitLab:~$ lsb_release -a

No LSB modules are available.
Distributor ID: Ubuntu
Description:    Ubuntu 22.04.1 LTS
Release:        22.04
Codename:       jammy

GitLab:~$ sudo apt-get upgrade gitlab-ce

Reading package lists... Done
Building dependency tree... Done
Reading state information... Done
gitlab-ce is already the newest version (13.12.15-ce.0).
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

GitLab:~$ sudo curl https://packages.gitlab.com/install/repositories/gitlab/gitlab-ce/script.deb.sh | sudo bash

  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100  6865  100  6865    0     0   6352      0  0:00:01  0:00:01 --:--:--  6374
Detected operating system as Ubuntu/jammy.
Checking for curl...
Detected curl...
Checking for gpg...
Detected gpg...
Running apt-get update... done.
Installing apt-transport-https... done.
Installing /etc/apt/sources.list.d/gitlab_gitlab-ce.list...done.
Importing packagecloud gpg key... done.
Running apt-get update... done.

The repository is setup! You can now install packages.

Can you suggest me a way to upgrade?
Thank you

GitLab repositories are not yet ready for Ubuntu22

I’ve solved using the focal repo:
curl https://packages.gitlab.com/install/repositories/gitlab/gitlab-ce/script.deb.sh | sudo os=ubuntu dist=focal bash

Hope it’is usefull

have a nice day

1 Like

You can follow the status on Ubuntu 22.04 LTS packages in Add packages for Ubuntu 22.04 (#6793) · Issues · GitLab.org / omnibus-gitlab · GitLab

Ok. So better is wait? I have ubuntu 22.04 and gitlab 15.2.2. Still ubuntu tell me, that i have last version, but Gitlab tell me “update asap”. I tried
“sudo curl https://packages.gitlab.com/install/repositories/gitlab/gitlab-ce/script.deb.sh | sudo bash”

But it is still the same.

Thanks you

There was a 15.2.3 and 15.3.0 and 15.3.1 were just released, all of which would be reasons for GitLab telling you to upgrade.

If you run jammy, I suspect that command (and never do that, piping unknown stuff downloaded from the web directly into a shell is a bad idea, when the shell runs as root it becomes an extremely bad idea - and there’s no point in executing curl as root) will not do anything useful, as it will probably make your sources.list.d/gitlab_gitlab-ce.list point to the still not existing jammy repo. Try to download the script, read it, and run the downloaded version with os=ubuntu dist=focal sudo ./script.deb.sh. (I’m actually unsure about where to put sudo in this case).

If the command starts with sudo it should work: sudo os=ubuntu dist=focal ./script.deb.sh