Unable to assign merge request to any user

Hello community, (originally posted in General)

I’m the owner and only user of my gitlab installation.
For some unknown reasons to me, I’m not able to assign merge requests to my account anymore (used to work). I’m “maintainer” of the repo.
The list of the “assignee” is empty and if I press the “assign to me” link, nothing happens.
The master branch is protected, but merge requests are allowed for the maintainers (of course…).

My installation is running on a docker container, using the image gitlab/gitlab-ce:latest (currently 13.7.1).

Is there a way to fetch the list of the possible assignee via API, to try to debug this issue?

Any input or idea?

More than a year ago (I don’t remember, and things might have changed since), one of my colleagues reported a problem assigning a merge request to another of my colleagues. It turned out that this particular colleague was the author of one of the commits in the MR, and GitLab removed the author of every commit from the list of possible assignees, probably from thinking they weren’t objective. I imagine something like that might be the case if you’re the only user of your GitLab instance (pretty much also means you’re the only likely author of commits).

Thank you grove for your input.
Indeed I’m the committer of the changes.
I tried to create a new user and I assigned it to the project.
Unfortunately the result is the same. The list of the assignee is empty :frowning:

It turned out to be a nginx setting issue on my reverse proxy (outside of the docker image). An exception was occurring in a JS file while fetching the assignee list.
The issue has been solved by setting the “Content-Security-Policy” header as suggested here: Implement Content-Security-Policy header (#3593) · Issues · GitLab.org / omnibus-gitlab · GitLab