Unable to locate package gitlab-ce

Trying to install gitlab-ce using the repository in the install doc. After I run the script to install the repository and update apt I get the error unable to locate package gitlab-ce

Script output

Detected operating system as debian/buster.
Checking for curl…
Detected curl…
Checking for gpg…
Detected gpg…
Running apt-get update… done.
Installing debian-archive-keyring which is needed for installing
apt-transport-https on many Debian systems.
Installing apt-transport-https… done.
Installing /etc/apt/sources.list.d/gitlab_gitlab-ce.list…done.
Importing packagecloud gpg key… done.
Running apt-get update… done.

The repository is setup! You can now install packages.

When I run apt-get I get this error

sudo EXTERNAL_URL=“https://example.here.com” apt-get install gitlab-ce
Reading package lists… Done
Building dependency tree
Reading state information… Done
E: Unable to locate package gitlab-ce

I would rather not install from source.

I also deleted all lists from /var/lib/apt/lists/ and ran apt-get update

Get:2 https://packages.gitlab.com/gitlab/gitlab-ce/debian buster InRelease [23.3 kB]

I can see that it has downloaded the list. Is there an issue I’m not aware of with buster 10.3 and gitlab?


can you retry this without the EXTERNAL_URL setting? I have just tested it with a Debian Buster Container, this works here.


I ended up doing a clean install of buster 10.3. That worked. Seems I had a bunch of i386 packages still on the system from my upgrade from stretch. Plus it was upgraded hardware to. System used to run on an old pentium 4 server.

Now I’m trying to get it to work with out a domain name. I don’t have a registered domain, so I’ve been using a private ip. Do I have to make a custom domain name entry to get around it?


how do you access servers in your network, e.g. is your DNS/DHCP setting a local domain e.g. company.localdomain or something like that? That’s more of a network management question though, if you are using IPs, that answer also helps.


At the moment I’m using IP’s. I don’t have a signed cert for ssl I’ve been running into an issue with letsencrypt. Tried disabling it by adding the line letsencrypt[‘enable’] = false into gitlab.rb

In the long run I’m going to be setting up my network with a private dns server forwarding requests for public domains to my ISP’s DNS or Googles DNS. With my router using a private IP pointing DNS to the private DNS server. DHCP will also send the private DNS server IP to DHCP clients. Servers and other clients needing a static ip will have static address assigned via a DHCP reservation.

The gitlab server will be behind the router with a private IP. Users will log into the network via VPN then access gitlab. For users not able to connect via VPN I’ll have a ddns hostname with no-ip.

The big issue it seems is the signed cert. I’d like to use https for the ddns log ins with an unsigned cert.