Unable to push code or commit to repository

Hello Greetings,
I am using Gitlab 14.1.6 and I am unable to commit a file from GUI since I get a 401 unauthorized also tried to push the code from git cli to repository but it gives out a ‘pre-recieve hook declined error’

Here is what it looks likes

git push -u origin master
Counting objects: 3, done.
Writing objects: 100% (3/3), 222 bytes | 222.00 KiB/s, done.
Total 3 (delta 0), reused 0 (delta 0)
remote: GitLab: 401 Unauthorized
To https://gitlaburl
! [remote rejected] master → master (pre-receive hook declined)
error: failed to push some refs to ‘https://gitlaburl

Things I tried are

  1. Full health check on server with
    gitlab-rake gitlab:check RAILS_ENV=production
    Everything shows fine

  2. Creating a branch and pushing data on it
    got the same error with (pre-receive hook declined)

  3. Checked if any hooks are created but there are none

  4. Checked if any branches are protected in repository settings but there are none

Please let me know what I can do to resolve this issue

401 Unauthorized is infamously misnamed. It really should have been called 401 Unauthenticated instead. Show the output of git remote -v. Scheme should be either https or ssh, each of which is configured in a different manner (git config).

thanks for replying,
here is the output of the git remote -v

git remote -v
origin https://abc.com/xyz/test123.git (fetch)
origin https://abc.com/xyz/test123.git (push)