Update GitLab 7.7.2 to latest version

Hi, I need to update to the latest version, I have GitLab 7.7.2.

What route should I follow?

Hi and welcome to the GitLab forum! :slight_smile:

Generally, you will have to upgrade in steps: first of all to the latest version of a series, then to the first version of a series, and then repeat the steps until you reach the version that you want to be at.

In your case the route would be something like this (please double-check before starting the upgrade process):

7.7.2 => 7.14.3 => 8.0.0 => 8.17 => 9.0 => 9.5 => 10.0 => 10.8 =>11.0.0 => 11.10

This might give you some more info as well:

Also check out the list of GitLab releases.

I wrote myself a documentation when I had to do the same thing you’re about to do. Hopefully this helps you out (you’ll have to change the version numbers to what is appropriate for your situation - this is just so you have an idea of the steps you need to do to get to where you want).


Version Naming Convention

(Major).(Minor).(Patch) - ex.: 10.7.3 where 10 is the major version, 7 is the minor version and 3 is the patch version numbers.

Official Documentation

As mentioned in the official GitLab Maintenance Policy, generally you should be able to easily and safely upgrade between patch versions and minor versions within the same major version. HOWEVER, upgrading from a major version to the next major version requires more attention.

The general practice should be to upgrade to the latest available version within your major version. Then proceed to upgrading to the next major version.

For example, when trying to upgrade from 10.7.3 to 11.5.0 - you first need to upgrade to the latest version of 10 which is 10.8.5 and then proceed to upgrading to 11.5.0.

Package Download Locations

All GitLab versions can be located in this package list.

When at 10.7.3

Ubuntu

sudo apt install gitlab-ce=10.8.5-ce.0

RHEL

sudo yum install gitlab-ce-10.8.5-ce.0.el7.x86_64

After the upgrade you might have to run (if GitLab is behaving in a weird way)

sudo gitlab-ctl restart

When at 10.8.5

Ubuntu

sudo apt-install gitlab-ce=11.5.0-ce.0

RHEL

sudo yum install gitlab-ce-11.5.0-ce.0.el7.x86_64
1 Like

Regards

Thank you I will review it

regards

1 Like

I recently had the same task of upgrading a v7.14.1 GitLab CE Omnibus (on Debian) to the latest available (at the time, it was v11.10.2) and I was very reluctant to do so… So here is my path if it can help you

I used gitlab-ce_XXX_amd64.deb packages (can be found here) installed via dpkg -i and did it in the following order:

  • Upgraded to v7.14.3
  • Upgraded to v8.17.8
  • Upgraded to v9.5.10
  • Upgraded to v10.8.7
  • Upgraded to v11.10.2

It went very smoothly (:clap: to GitLab team for such great migration scripts/code).

The only 2 issues I ran into were:

  • I am using my own reverse proxy in front of Omnibus’s Nginx server and, prior to v8, the built-in Nginx server or the Chef recipe didn’t supported some headers such as X-Forwarded-Proto) so the following gitlab.rb settings produced a Nginx configuration were I could not login:
    nginx['proxy_set_headers'] = {
      "X-Forwarded-Proto" => "http"
    }
    
    But I could manually fix the Nginx configuration and/or upgrade v8+ were such issue was fixed.
  • After v11.10.2: I had to add my own TLS certificate to /etc/gitlab/trusted-certs/ for LDAP connection to work (my LDAP server uses a self-signed certificate).

Since then, I added the GitLab’s Debian repository and simply upgraded GitLab using aptitude upgrade.

1 Like

Best regard

This way the update worked.

Thank you