Upgrade 10.8.4 to 11 Fails


#1

Attempting to upgrade to 11 (as the admin suggests ASAP). Receiving the following error on apt-get upgrade:

After this operation, 32.2 MB of additional disk space will be used.
(Reading database … 150281 files and directories currently installed.)
Preparing to unpack …/gitlab-ce_11.0.2-ce.0_amd64.deb …

  • git_data_dir has been deprecated since 8.10 and removed in 11.0. Use git_data_dirs instead.
    Deprecations found. Please correct them and try again.
    dpkg: error processing archive /var/cache/apt/archives/gitlab-ce_11.0.2-ce.0_amd64.deb (–unpack):
    subprocess new pre-installation script returned error exit status 1
    Errors were encountered while processing:
    /var/cache/apt/archives/gitlab-ce_11.0.2-ce.0_amd64.deb
    E: Sub-process /usr/bin/dpkg returned an error code (1)

#2

Solved after reading other posts and editing the config appropriately:

#ruby git_data_dir “/Volumes/Local/gitlab/git-data”
ruby git_data_dirs({
“default” => {
“path” => “/Volumes/Local/gitlab/git-data”
}
})


#3

Hi,

I have a problem that I think it may relate.

I upgraded gitlab-ce 10.8.5 to 11.0.2 and ever since then I cannot browse my server. All that I get is a “Service Unavailable” error.

I updated my git_data_dirs as explained and the problem is still there.

When I run gitlab-rake gitlab:check gitlab-shell self-check fails, but the configuration seems ok.

I tried to move back to gitlab-ce 10.8.5 and I still have the same error 503 (although this time with a big gitlab logo on the screen).

Any idea what is going on or how to debug?

Thank you very much in advance.

Regards,
Javier


#6

https://docs.gitlab.com/ee/update/10.8-to-11.0.html


#7

I have the same problem. apt-get says: “git_data_dir has been deprecated since 8.10 and removed in 11.0. Use git_data_dirs instead.” However, my /etc/gitlab/gitlab.rb has the newer git_data_dirs already. Is there any other place where git_data_dir needs to be replaced?


#8

I found the problem. You need to invoke sudo gitlab-ctl reconfigure after the change to gitlab.rb. A restart of the server is not enough.