Upgrading Gitlab CE server from version 8.13.6 to latest version


I have recently started at my new role as a Devops engineer and have found the self-hosted Gitlab server is on version 8.13.6. After a minor heart-attack, I decided to upgrade the server to the latest verison. I tried the usual yum update but it failed promptly so i decided to do a backup and trying to restoring the backup onto a new version of the app but as you all know that didn’t work. I read everything i could fine on upgrading from older version of gitlab ce to the lastest and found this helpful post. Migrate 8.17.6 to 11.5.0

My ques is, is there a quicker way of upgrading from version 8.13 to 11. 9. I have carried out dry runs of upgrading from major version to major version and i get varied problems when trying to do so. Please help.

I don’t think there’s a faster way. As suggested in that thread, it might help to upgrade to intermediate minor versions.

When I took over administration of our self-hosted GitLab server (or more precisely: when I found time to take care of it, after sorting out all the other messes I had been left with), I spend a couple of hours some evening (in order not to interrupt work for the colleagues who also uses GitLab) upgrading through every minor version (i.e. the second part of the version number), taking the first and last patch release. Probably overly cautious, and slow (but it was luckily only 6 or 7 minor versions).

Thanks Grove. I was trying my luck in case someone had tried something new and had a new approach. My pain keeps on growing. I just realised that when doing the upgrade that at around 11.4 or later the upgrade crashes as there is not enough disk space on the volume where the /opt/gitlab is mounted. I couldn’t unmount the mount point to expand the volume because there are a lot of files open (even after doing gitlab-ctl stop). Any advise on stopping Gitlab completely?