While pushing docker container i am getting denied access forbidden

I am new to gitlab and docker images/containers so forgive me if this is a super simple question.

I have a private project that I was working on late last year and had to take some time off. Today, when i try to deploy my container using docker cmdline, I am getting the following error:

denied: access forbidden

When using the docker Desktop i get:

unauthorized: HTTP Basic: Access denied. The provided password or token is incorrect or your account has 2FA enabled and you must use a personal access token instead of a password. See Two-factor authentication | GitLab

I have read several posts on the gitlab forum but cant get anything to work. I have TRIED to create access tokens but that does not work (maybe i am doing something wrong)

I can login to the web ui using my credentials.

i tried several solutions but the latest was issuing the following cmds:
docker login “https://gitlab.com/privateProjectDetails” -u username -p password
docker push registry.gitlab.com/privateProjectDetails:tag

where the username and pwd are what successfully log me into the website.

I dont know what to do next…any help would be much appreciated.

Hi there,

I see you’ve tried to login directly to GitLab, instead of GitLab’s Registry.
Can you try to do:

docker login registry.gitlab.com -u username


Let me know what that gives you.

I am an idiot…THANK YOU. it worked exactly as i expected.

1 Like