Add existing Kubernetes cluster integration

Since a few days I can’t seem to be able to connect to an existing Kubernetes cluster.
I’ve followed the following steps.

I’ve created a new cluster in western europe 3 a (Frankfurt)

  • VPC-native enabled
  • Basic authentication disabled
  • Client certificate disabled
  • Legacy authentication disabled
    (also tried with these enabled, and in the past I’ve been able to keep these disabled without problems)

Then I did the following:

  • Get the API URL,
  • Get the CA Token
  • Create a “gitlab-admin” service account in the “kube-system” namespace clusterrole binding: cluster-admin (Note that I’ve also tried to create this user in the project namespace.
  • Get that service accounts token

Put all that in the gitlab form where you couple an existing cluster. As soon as I save it says the following:
“There was a problem authenticating with your cluster. Please ensure your CA Certificate and Token are valid.”

This worked 100% before, and doesn’t now. And I’m not sure how to debug this problem. Any help is appreciated. One last thing I’d like to add. It seemed that before Gitlab created a “[namespace]-service-account” when coupling an existing cluster.

1 Like