Attempt import project from old server fails

Hello Gitlab community,

I have the following problem and would appreciate some help.

Currently, I have a GitLab instance the version is Community Edition 11.0.0. I have installed a new GitLab instance (Community Edition 15.5.4) and wanted to move some existing repositories to the new server. I exported the project on the old server and then tried
to import the project on the new server. I select the project.tar.gz
file and get the error below

1 Like

To remove any problems with incompatible gitlab-ce versions, I exported a project from gitlab-ce 15.5.4 and then tried to import it, with the same error. The exported file is a valid .tar.gz file

How are you exporting the project exactly? Via clicking project β†’ Settings β†’ General β†’ Advanced and then the export button. Or are you downloading it using the download option from main project screen and then selecting tar.gz?

I have just managed to successfully export on Gitlab 15.5.4 and import without problems. But I use the option under Settings β†’ General β†’ Advanced and then click the export button. Later once it finished I downloaded the export from the link provided under Settings β†’ General β†’ Advanced β†’ Export section

Thanks, I export via Click project, Settings β†’ General β†’ Advanced and then the export button. I do not receive an email with a link so after a while I use the download export option which gives a filename of date_time_user_project_export.tar.gz. Which looks like what you do

Yep, that’s what I did. My test instance isn’t configured for email, so I just clicked the button. I then imported it perfectly fine on my test instance. Let me try on gitlab.com to see if it imports there.

EDIT: yes it worked fine on gitlab.com as well. Sounds like something is wrong on your install if it cannot export, although I have no idea what. For me it just works.

Thanks again, one last thing are you using nginx ? I’m using apache

Using built-in nginx that comes with Gitlab.