Branch got deleted after getting error 503


I hope this post finds you well.

Today when I tried to push to my development branch i got an error message saying:

The requested URL returned error: 503

The same happened when i then tried to go to my repository using the web interface.
This lasted for about 10 minutes but after that my development branch had gotten deleted.
I still had my changes locally to I could create a new branch and push them there, but my read question are:
can I see in the log which user deleted the branch?
Has anyone experienced this before ( loosing branches after getting error 503 )?

Best regards


we are facing same issue. Multiple branches, including master and development branch dissapeared - not only from UI, but also from repository.



I tried to push to master again, but I got this error

➜ git push
remote: error: cannot lock ref 'refs/heads/master': unable to resolve reference 'refs/heads/master': reference broken
 ! [remote rejected]         master -> master (failed to update ref)
error: failed to push some refs to '[REDACTED]'

Hi I had the exact same issue. It just happened.
When I tried to pull this log occured:

> ➜  git pull
remote: The git server, Gitaly, is not available at this time. Please contact your administrator.
fatal: unable to access '': The requested URL returned error: 503`


➜  git pull                     
Your configuration specifies to merge with the ref 'refs/heads/kevinsTestBranch'
from the remote, but no such ref was fetched.

And push:

➜  git push
Total 0 (delta 0), reused 0 (delta 0)
remote: error: cannot lock ref 'refs/heads/kevinsTestBranch': unable to resolve reference 'refs/heads/kevinsTestBranch': reference broken
 ! [remote rejected]   kevinsTestBranch -> kevinsTestBranch (failed to update ref)
error: failed to push some refs to ''

How can you continue development without the master branch?
That is way more severe than my issue I cannot create branches with the same names as the deleted ones, but I can still push our changes to new ones.

These are the exact error messages we are getting as well.
First, we got the error 503 and our repository disappeared from the homepage as well. Then after it came back the branch we tried to use got deleted.

@michael_and @tomas.k @j9hnny @kevinrobots Hey all :wave: , first of all I apologize for the issue here.

Could you all let me know if you’re still affected by this issue at all or if you were able to restore the missing refs? If you are still affected in some way please feel free to either open a support ticket including the paths to the affected projects or post them here if you’re alright with it being public.



Hi Tristan,

Branches are back and working from yesterday morning. So we can consider it as resolved.

1 Like

Hi Tristan

My branches are also back and everything is working on my end as it did before the issue.
Thank you for looking into the issue

1 Like