Cannot delete repo, images or tags

Hey everyone,
At my workplace we’re running Gitlab through an Omnibus installation that’s running self-hosted in a Docker container. We all access Gitlab and Mattermost through this installation on our personal machines. Our Gitlab version is 16.4
There are some old repos that we’ve been trying to get rid of, but I’ve had a lot of issues with.
Before I tried any of the below, I was also sure to add myself to the project as an Owner, for full access.

Through the web GUI, I’ve tried deleting them from the repo settings page - ‘This project was scheduled for deletion, but failed with the following message: Failed to remove some tags in project container registry. Please try again or contact administrator.’

Each repo has container registry images. Trying to delete those yields (in the HTTP response): “The resource that you are attempting to access does not exist or you don’t have permission to perform this action”

Going into each of the images and trying to delete the tags yields the same response.

I’ve monitored the logs of the docker container, and for the most part the error will be something like:
permission denied" error=“unknown: unknown error”

I’ve tried manually triggering the cleanup, pruning unreachable objects, basically anything I could find through extensive Googling, but no luck whatsoever.

Marking the repos for deletion actually caused a pretty big problem, with the container logs generating gigabytes of log files from the cleanup constantly trying to delete but failing. Got that under control though.

Anyone have any ideas?