Can't Access Public Pipeline of Public Repository


Unable to access Pipeline Dashboard and Artifacts without Authentication

I have a public group, with projects that are all public with pipelines set to “Everyone With Access”.

All of my repos are perfectly fine however except one of them is behaving as if the pipelines are private even though they aren’t. I can access the repo itself without authentication but not the pipelines or artifacts of them.

I should be able to simply view and download the artifacts from an unauthenticated session.

I’m using the public instance of GitLab.

The repo that’s having the problem can be found here:

I’ve tried changing the settings to be more public and more private. I’ve also made the repo private then public again, I’ve tried refreshing my cache or just trying other browsers, but nothing seems to help. I’ve navigating all the settings further to see if anything else could be causing the problem and also checked the group settings.

Hey @iSeth, this is because this setting (Public Pipelines) is disabled on that project.

I hope that helps!

Sorry about that, and thank you very much.
I tried skimming the settings and searching but only ran into the general visibility settings.

If I’m welcome to ask a question, isn’t it worth mentioning this in the Project visibility settings as well?

@iSeth No worries at all, it’s easy to miss a setting.

isn’t it worth mentioning this in the Project visibility settings as well?

If I were to guess, I’d imagine there isn’t a mention of that within the project visibility settings as they both handle two different parts of the project permission structure. However, if you feel that should change please feel free to submit a feature proposal issue.