Can't add badge in my gitlab installation

Hi,

I’m trying to add badges to my projects and groups in my own gitlab instance.
When doing this (both project and group level) i get the error message to check the URL.

Then i created a project on gitlab.com and there it worked without any trouble (Adding the very same link, so pointing to my private gitlab instance)

Is there anything in the configuration which could be wrong? Where should i search to fix this?

Infos about the installation:

GitLab 11.4.5 (f5536c6)
GitLab Shell 8.3.3
GitLab Workhorse v7.0.0
GitLab API v4
GitLab Pages 1.1.0
Ruby 2.4.5p335
Rails 4.2.10
postgresql 9.6.8

Im using the docker variant.
On my server there is a apache running (serving as proxy)
All requests are redirected to https (letsencrypt, valid certificate)

I haven’t created an issue on the tracker yet since it may be a configuration issue (since it works on the official gitlab)

Regards and Thanks in advance

Good work on adding detailed info about your installation.

What does the error message say exactly? What “Badge image URL” are you using? Is the URL available to your server?

Hi,

when i tried on the project level, i used the URLs generated by the CI / Pipeline section in the settings - this badge is working in my README.md like a charm.

When going to group level to try out (and even before) i wanted to get familiar with variables. So i used the following:

// For URL
https://gitlab.kagu-chan.de/%{project_path}/commit/%{commit_sha}

// For SVG
http://gitlab.kagu-chan.de/%{project_path}/badges/%{default_branch}/pipeline.svg

// The Code from the README.md where i exactly copied the first version:
[![pipeline status](http://gitlab.kagu-chan.de/honor/api/badges/master/pipeline.svg)](http://gitlab.kagu-chan.de/honor/api/commits/master)

As well i have one gitlab-pages URL generated by gitlab which wasn’t usable as well. I tried both HTTP and HTTPS.

The Error Message:

Adding the badge failed, please check the entered URLs and try again.

My gitlab don’t know that it supports HTTPS (proxy / letsencrypt setup) - may this be a reason? But then im still wondering why it generated me this badges URL above but does not allow me to use it this way. As well this exact URLs are working on the public gitlab (hence without finding an image, since there is no authentication to my gitlab at all)
I could think of a check if gitlab can reach the svg, but doing this server side where it is called via docker ip / proxy, which may fail…

Thanks for your answer so far (: and regards