Can't push to remote : ReadOnly

Hello all,

I must say I’m a bit fedup. Since 2 days, I can’t push to gitlab one of my private repository :

"The repository is temporarily read-only (WTF?).Please try again later. Fatal : unable to access ‘myrepo’. The requested URL returned error : 403…

So what should I do ? I NEED to push. Others private repos are working fine !


Hello! Do you know the actual size of your repo? If if exceeds the limit allowed maybe this is the reason why you cannot push to remote.

Hey @mathieu ,

Thanks for your answer. Yes its quite huge (2Go). Where can I find the limit allowed ?

Edit : found out limit size is 10Go …

You are right. Default limit is set to 10Go. Is your repository bigger than 10Go? If no, the problem is probably not related to the size of the repo.

No its not, its about 2GO as I said …

Oh, my bad I missed that info. Is your branch you try to push to protected? Are you able to push another (or a new) branch to remote?

Hey @mathieu .

Nope I’m trying to push to my dev branch which is not protected, only branch I got protected is master.

And yes I already tried to create a branch as you suggested, but pushing the new branch gives me same error …

Thank you for your answers. If you take a look at the Project Members, what is your Role?
Also, do you know if you authenticated with your user/pass or with a token?

I’m the maintainer and creator of the repo, so this is not a matter of rights.
Yes, I’m authenticated with my user/password through GIT.

Thanks for your time :slight_smile:

Did you try to create a branch from the web then create a new file from the web and commit this new file?
Just to be sure. Is it a self hosted instance of CE? Did you look at the server logs?

Hello @mathieu,

Thanks for your answers. I have been in contact with GitLab support, and they have finally fixed the bug. They did not give me the real reason why I had this error … Seems to be from multiple reasons, or a specific action that had been done at a specific time. Well that’s fixed and that’s the most important.

Thank you again.