Datarecovery from 16.9.1 to 16.10.2

:hugs: Please help fill in this template with all the details to help others help you more efficiently. Use formatting blocks for code, config, logs and ensure to remove sensitive data.

Problem to solve

servercrashed with ver 16.9.1, new server install with 16.10.2:

Steps to reproduce



On self-managed instances, add the relevant configuration settings or changes.
The old server drive is attached to new VM with old data intact.
I need to restore data from old server to new (from version 16.9.1 to 16.10.2)


Please select whether options apply, and add the version information.

  • Self-managed


  • Old: 16.9.1
  • New: 16.10.2

Helpful resources

  1. Before opening a new topic, make sure to search for keywords in the forum search

I did check below article. Just wanted to confirm if there is anything additional needed for the specific versions I am running?

Thanks for taking the time to be thorough in your request, it really helps! :blush:

Please and Thank You,

Ok just to update:

Since it is VM I did screenshot it and tried to restore data on 16.10.2 it did not go well.

I removed the 16.10 and install 16.9.1 and copied the mentioned 2 directories and ran reconfigure. Its at
Waiting for gitlab to boot and below services status.
ftsadmin@ca-fts-itm1:~$ sudo gitlab-ctl status
down: alertmanager: 1s, normally up, want up; run: log: (pid 33610) 8s
down: gitaly: 1s, normally up, want up; run: log: (pid 33612) 8s
run: gitlab-exporter: (pid 33632) 8s; run: log: (pid 33629) 8s
run: gitlab-kas: (pid 33635) 8s; run: log: (pid 33624) 8s
run: gitlab-workhorse: (pid 33638) 8s; run: log: (pid 33628) 8s
run: logrotate: (pid 33630) 8s; run: log: (pid 33620) 8s
run: nginx: (pid 33634) 8s; run: log: (pid 33623) 8s
run: node-exporter: (pid 33640) 8s; run: log: (pid 33637) 8s
run: postgres-exporter: (pid 33618) 8s; run: log: (pid 33614) 8s
down: postgresql: 1s, normally up, want up; run: log: (pid 33615) 8s
down: prometheus: 1s, normally up, want up; run: log: (pid 33613) 8s
run: puma: (pid 33626) 8s; run: log: (pid 33622) 8s
run: redis: (pid 33636) 8s; run: log: (pid 33627) 8s
run: redis-exporter: (pid 33631) 8s; run: log: (pid 33621) 8s
run: sidekiq: (pid 33633) 8s; run: log: (pid 33625) 8s

Any suggestion please.

Thank You,

ok just to update. I reinstalled new server with same OS and installed gitlab CE 16.9.1. After following steps above everything was restored. Earlier I was trying on latest OS ver.

Below definitely worked.


1 Like