Default root password for GitLab running in a Docker container?

Hello, I just installed gitlab on my Synology in Docker with the image gitlab/gitlab-ce:latest.

The installation went fine and I can bring up the page. It is asking me for a userame/password to log in. All the guides I see out on the net show it should prompt me to set the root password… but it doesn’t. Is there a set default username/password on this image?

The attached image is what comes up right after installation. Thanks for any help!!

I just deleted the container and rebuilt it from scratch and I’m still not given the opportunity to create the root password. Same login screen.

I haven’t tried installing GitLab with docker, but the documentation for doing so

speaks about the initial root password.

Hi,

IIRC Synology ships its own outdated Docker container image for gitlab-ce. Can you share the steps on the terminal you used to run the container, specifically where the image is coming from?

Cheers,
Michael

I’m a bit late… just in case did you try, from synology with ssh access (that’s another story but you may easily find how to enable it)

sudo docker ps
(you will get container id among other things)

sudo docker exec -it grep ‘Password:’ /etc/gitlab/initial_root_password

to get … initial default password

Kindly use the following command below… It will help.
sudo gitlab-rake “gitlab:password:reset”

1 Like

How do you change the root password, i.e. the one in initial_root_password.
I assume I have to go via some docker command because I get
“gitlab-rake: command not found”

I installed gitlab with docker as follows:

export GITLAB_HOME=/srv/gitlab
sudo docker run --detach
–hostname 192.168.151.150
–publish 192.168.151.150:443:443
–publish 192.168.151.150:80:80
–publish 192.168.151.150:9222:22
–name gitlab
–restart always
–volume $GITLAB_HOME/config:/etc/gitlab
–volume $GITLAB_HOME/logs:/var/log/gitlab
–volume $GITLAB_HOME/data:/var/opt/gitlab
–shm-size 256m
gitlab/gitlab-ce:latest

Thanks.

Login to the web interface on https port 443 using the url for your installation or even the Ip address. Your install might even be on just http port 80 as well depending on your external_url configured during installation.

The web interface will automatically ask you to change the password from the initial one.

I followed the link below. Yes my gitlab is running as a container,

  1. docker ps
  2. docker exec -it gitlab bash <= that is my container name in step 1
    3 gitlab-rails console -e production <= wait, minutes for another prompt to come
  3. user = User.where(id: 1).first
  4. user.password = ‘secret_pass’ <= use your favorite password
  5. user.password_confirmation = 'secret_pass <= again
  6. user.save! <= save user

Reset the password of the root account in gitlab in docker - Programmer All

Yeah that also works :slight_smile:

A post was split to a new topic: Default root password problem with AWS EC2 GitLab Ubuntu AMI