Error 422 when attempting to log in

I self host an omnibus package of gitlab 11.3.1 on CentOS 7 behind an nginx reverse-proxy.
I have had no issues in the past with this and for a while it was working perfectly fine.

Recently I have been unable to log into my web front-end of my gitlab server. I can push/pull repos and everything. But when I attempt to log in, even with a fake account. I get redirected to error 422. Maybe it’s related to the 11.3.0 update since that’s when I started having the issue, although not right away. It can’t be a cache issues since I tried logging into the server via which would have never logged into this server before.

I am at a loss. I even re-installed a fresh version of gitlab, not running behind a proxy and I can’t even set the root password because it goes to 422.

I also noticed registering for these forums, I cannot log in with google because I get redirected to 422. Maybe there’s an issue with 11.3.x after all.

Any help would do.

I have fixed the issue.

My server that was hosting the gitlab package was 4 hours behind, causing authentication token issues.


Great, glad you worked it out, and thanks for posting the solution to help other forum members in a similar situation!