Failed to Create Ceritificate on GitLab CE

Describe your question in as much detail as possible:
What Can I do to be able to get the certificate and publish a self hosted git lab instance ?

  • What are you seeing, and how does it differ from what you expect to see?
    I expect to see the gitlab home screen according to the tutorial from digital ocean
  • Consider including screenshots, error messages, and/or other helpful visuals
  • What version are you on (Hint: /help) ? and are you using self-managed or
    I’m trying to install GitLab Comunity Edition using this guide: How To Install and Configure GitLab on Ubuntu 18.04 | DigitalOcean
  • What troubleshooting steps have you already taken? Can you link to any docs or other resources so we know where you have been?
  1. Followed the steps here: SSL Configuration | GitLab and my problem seems to be the number 2, but didn’t knew how to proceed forward then i ran the test using letdebug to try to see why I couldn’t get a certificate
  2. I use this to try to debug the cause of the error Let's Debug
  3. Tried the solutions mentioned here: LetsEncrypt certificates fail in domain validation - #8 by thomas.isaksen
  4. This are the changes that I’ve done so far to the configuration:
    external_url ‘

    letsencrypt[‘enable’] = true

    nginx[‘redirect_http_to_https’] = true
    nginx[‘redirect_http_to_https_port’] = 80
    nginx[‘custom_gitlab_server_config’] = “location /.well-known/acme-challenge/ {\n root /var/opt/gitlab/nginx/www/; \n}\n”

Thanks for taking the time to be thorough in your request, it really helps! :blush: