Git Credential Manager ask to sign in a lot

I use VScode for my work and use both Gitlab and GitHub but Gitlab asks me to sign in a lot.
I set Vscode auto fetch new commits from remove and it shows up a lot, never happens with GitHub

My environment:
Windows 10,11
WSL version:, Kernel version:
Git version Wsl: 2.42.0, Windows: git version
Git credential-manager --version 2.3.2 installed with git for Windows above
My git config from wsl:
credential.helper=/mnt/c/Program\ Files/Git/mingw64/bin/git-credential-manager.exe

I tried a few advice from the internet: log in with email and password (usually I use Google account), then enable 2FA but nothing worked. I know that if I change credential.helper to “store” or use ssh will solve my problem with git access, but this seems to be an issue

I’ve had a similar problem with my work laptop lately. For me, it occurred after installing “Git for Windows” v2.42.

It had worked fine on my prior version (v2.39), but for whatever reason, the newer install made this pop up appear every time I did a “git push/fetch/pull”.

Oddly, I seem to be the only colleague at the company affected by the issue, others aren’t seeing this.

I also tried googling for answers online, tried various suggestions that didn’t help.

In the end, one colleague suggested trying “github cli” (as our company uses github for housing its repos). While “github cli” isn’t really a replacement for ‘git’, I did notice that when I configured it with “gh auth login”, it authenticated to github with a “one-time” code (it opened my web-browser to github where I could type that one code in), and that was the end of it.

After this point, every “gh” command worked fine, without pestering me for further credentials (e.g. “gh status”).

That made me suspicious. Why did “git” keep pestering me for credentials, while “gh” didn’t?!?!

That’s when I noticed “gh” had an option to configure “git” so that it uses “gh” as its credentials manager/helper via typing this command:

gh auth setup-git

…and to my pleasant/unexpected surprise, I could now do “git push/pull/fetch” with no more annoying credential popups!

Anyways, not sure if it will help in your circumstance, but just thought I’d share, in-case there’s any useful clues/insights that might help.