Gitlab-ce proxy problem after upgrade to 11.11.8

Hi everyone !
We recently upgraded our gitlab-ce instance from 10.x to 11.11.8. I tried to enable a Slack notifications webhook to a new project, but noticed that “Test settings and save changes” fails with “Validations failed. Webhook is blocked: Host cannot be resolved or invalid”.
We are behind company firewall and proxy, which is perfectly set for our Redhat 7 environment, and also
for gitlab in /etc/gitlab/gitlab.rb:

gitlab_rails['env'] = {
    "http_proxy" => "http://proxy:3128",
    "https_proxy" => "https://proxy:3128",
    "no_proxy"   => "local.jenkins"

gitlab_workhorse['env'] = {
    "http_proxy" => "http://proxy:3128",
    "https_proxy" => "https://proxy:3128",
    "no_proxy"   => "local.jenkins"

It seems integration doesnt use these settings to call a webhook on, but eg.Help/Help can show that “update available”, therefore I suppose that other gitlab components can reach the internet through the proxy. From shell curl, wget etc everything is working fine…

Before the upgrade this worked with the configuration above.

Thanks in advance !

1 Like

I have the exact same problem here after an upgrade from 11.11.3 to 11.11.8. We cannot create new projects cloning an external repository nor call web hooks on an external domain (e.g. mircrosoft teams integration). All of this was working like a charm prior to the upgrade.

I cannot spot any specific errors in the logs beside that “url could not be resolved or is invalid”. As the author above, I tested the proxy settings from the server using curl, wget, even yum and there is absolutely no problem. It looks like gitlab is totally ignoring the proxy settings in the rails environment.

Update after some tests last night and today. This is apparently fixed in the latest gitlab version. This is the upgrade path I’ve tested:
11.11.3 (my previous version): OK
11.11.8: KO
12.0.9: KO
12.1.14: KO
12.2.8: KO
12.3.5: OK