GitLab CI does not get triggered for a commit from Local machine

Dear Team,

My pipeline doesnt get triggered automatically when the commit is made from any local machine. Pipeline works on commit made to files on GitLab UI, One merge requests and manual run from CI/CD screen.

There is no pipeline button next to the repository commit history. Attached the screenshot. It used to work fine before upgrading from 11 to 14 version.

  • *GitLab : GitLab Enterprise Edition [14.8.2-ee]
  • *Runner: gitlab-runner 14.8.2

.gitlab-ci.yml is simple created from templates…

I have created new project with basic configuration . it seems the behavior is consistent throughout this instance of GitLab. Tried adding tags to both commit request and docker runner. nothing helped. Tried changing all the settings. nothing helped.

Highly appreciate if someone could point out the root cause of the issue. Thanks

Did some research. Adding workflow is not helping either.

Found another possible reason for this problem: Gitlab-CI not triggering builds on commit - Stack Overflow

Disabling this setting in GitLab UI did not help. Looks like we need to make a direct change in the GitLab server: /opt/gitlab/embedded/service/gitlab-shell/hooks

I am updating here so that anyone facing similar problem can troubleshoot quicker. Its sad that I could not get any help after posting question on this forum.

Hi @bhuvanbondel

I would check what’s your rules on your jobs if they don’t disable jobs from push. Manual trigger from UI and push are 2 different pipeline sources.

Also any hooks you might have on an instance level.

There are no rules in pipeline. Pipeline with single job with just echo command doesnt run. Mostly to do with hooks configured. last thing we tried to do is to configure Jira integration with GitLab which failed due to connectivity issue, But disabling that integration is still not fixing the current issue. Next thing I am trying to do is to check the logs for any errors.

Found the error in the log:

{“correlation_id”:“01FYRKHWR823KGJRH60MF5ZGCM”,“duration_ms”:401,“error”:“badgateway: failed to receive response: context canceled”,“level”:“error”,“method”:“GET”,“msg”:"",“time”:“2022-03-22T10:42:54Z”,“uri”:"/project/test"}
{“severity”:“WARN”,“time”:“2022-03-22T10:43:48.617Z”,“message”:“Job arguments to ExternalServiceReactiveCachingWorker do not serialize to JSON safely. This will raise an error in\nSidekiq 7.0. See Best Practices · mperham/sidekiq Wiki · GitHub or raise an error today\nby calling Sidekiq.strict_args! during Sidekiq initialization.\n”}

With the help of GitLab admin. Unticked the Jira Integration - Active button. Even though Integration was not active. After this change everything worked fine.